Results 1 to 3 of 3
  1. #1

    2001 - Pro 1200 - MFD Display Issue

    Hi,

    The jetski runs and everything however the guages are not displaying anything. No oil indicators or and LCD dispay working. If it was the MFD, wouldn't the Jetski not start? Or could it actually run and the MFD still be bad?

    Thanks,

    Sam


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    it will run if the MFD isn't working ,check the fuse in the electrical box

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,572
    +1
    1,272
    Only replace the MFD fuse with another 1/4 Amp fuse, not a larger capacity fuse.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Polaris pro 1200 a few issues
    By sltfan777 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-06-2016, 10:50 AM
  2. 2001 Pro 1200 great condition
    By POLARIS PRO in forum Polaris Skis
    Replies: 59
    Last Post: 05-14-2009, 05:06 PM
  3. WTB: 2001 Pro 1200 Multi-Function Guage
    By elwayisgod in forum Polaris Classifieds
    Replies: 3
    Last Post: 07-08-2008, 11:18 PM
  4. 2001 pro 1200 cylinders
    By rgard32 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-22-2007, 02:55 PM
  5. 2001 Pro 1200 In Michigan Blown Motor
    By beerdart in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-25-2006, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •