Results 1 to 10 of 10
  1. #1

    2008 RXT-X Vibration

    I have a 2008 RXT-X and at 4900 RPM it has a vibration and keeps going to WOT.It will tingle my toes thru the hall.I have a 04 rxp with a x charger on it and no vibration.This is my 15 new ski and never experience this before.The charger comes in hard around 5,000 rpm could it be out of balance? I have around 35 HRS on it and still the same.Anybody experience this or any suggestions.


  2. #2

    Question 2008 RXT-X Vibration Problem

    I have a 2008 RXT-X and at 4900 RPM it has a vibration and keeps going to WOT.It will tingle my toes thru the hall.I have a 04 rxp with a x charger on it and no vibration.This is my 15 new ski and never experience this before.The charger comes in hard around 5,000 rpm could it be out of balance? I have around 35 HRS on it and still the same.Anybody experience this or any suggestions.

  3. #3
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    ITs the stock X intake grate. You dont see it with the Riva or R and D but I do get some feed back with a worx intake grate on my T-X.
    Yes it was very noticeable at cruising speed with stock X grate. Its a plow. Just take a peek at it.

  4. #4

    Exclamation rxt-x vibration

    I have never ran it with the stock grate.installed the R&D before it hit the water.Everything else is stock.

  5. #5
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by tom ihle View Post
    I have never ran it with the stock grate.installed the R&D before it hit the water.Everything else is stock.
    how many hours. I noticed more vibration when breaking it in, thats all i know.

    Edit, just noticed you stated 35 hours. HMM, might check alignment. You can pull your pump, prop, and look at wear ring to see if is worn funny which can be from alignment.

  6. #6
    Look in the intake grate and check if the nose came off the impeller!

  7. #7
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4
    Also, check to see if the stock rubber nose cone came apart... it is actually made of two pieces that sometimes separate.

  8. #8
    TERRY bigbuck12345's Avatar
    Join Date
    Aug 2007
    Location
    jacksonville fl
    Posts
    1,469
    Look and see if you have a small piece of wood stuck in your prop ??

  9. #9

    Exclamation rxt-x vibration

    nose cone fine and tight on prop-no wood.I think that the charger is out of balance?As soon as the boost comes on hard and the hoses start to expaind is when the vib starts and goes to wot.I have taking long trips and from idle to 4800rpm its fine.After 4900 its vibs.Maybe its dealer time-I just dont want to be down for weeks in the middle of summer.

  10. #10
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    The SC is spinning approximately 5 times faster than the engine, so at 4800 rpms, the SC is spinning at somewhere around 24,000 rpms. It could be just the weak hoses as metal pipes are being offered to replace these hoses. It could also be the OEM impeller as many have verified that some of these impellers are way off (as far as pitch goes) from the BRP factory... Ron

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2008 RXT X Modified intake grate
    By STSPERFORMANCE in forum 4-Tec Performance
    Replies: 40
    Last Post: 02-02-2008, 10:16 AM
  2. 2008 RXT vs. GTX
    By faxon in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-17-2007, 08:44 PM
  3. 2008 Rxt-x Rxp-x
    By DandSPro in forum Sea Doo Open Discussion
    Replies: 35
    Last Post: 10-12-2007, 07:04 PM
  4. 2007 RXT Driveline Vibration
    By motorsport17 in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-28-2007, 01:36 AM
  5. 2008 Rxt-x........ugly
    By cdalesch in forum 4-Tec Performance
    Replies: 27
    Last Post: 08-19-2007, 08:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •