Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 42
  1. #1
    ERICG1's Avatar
    Join Date
    Dec 2006
    Location
    WATERWORLD
    Posts
    469
    +1
    1

    Need help fast !!!!!!!!!!!!!

    I think the bumper came off of my driveshaft ( 06 RXT ) and I can't get the pump back on. IT will not seat the pump seal. PLEASE I NEED HELP NOW. I am leaving in 21 hours and taking all my boats across country. FRONT BUMPER THAT IS


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Pull the shaft and have a look! What led up to this... you say you have the pump off... what seal won't seat up

  3. #3
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    If you had the drive shaft out its possible the plastic hat came off end of drive shaft and its not letting it go all the way in. If this is the case it should have been a big PITA to get c clip on shaft with that extra pressure on boot.
    Be sure you dont have anything that fell down in prop threads.
    Pull shaft and if it does not come out on shaft then look in side and see what postion is sitting in.
    It should look like this if come out on shaft.
    Sorry dont have good pic down into PTO to show you where the cap sits.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC05886.JPG 
Views:	41 
Size:	607.1 KB 
ID:	141728   Click image for larger version. 

Name:	DSC05887.JPG 
Views:	41 
Size:	619.0 KB 
ID:	141729  

  4. #4
    ERICG1's Avatar
    Join Date
    Dec 2006
    Location
    WATERWORLD
    Posts
    469
    +1
    1
    Thats exactly what i think happened. I think the f***** front plastic cone came off !! What the hell do i do ???????????????????

  5. #5
    ERICG1's Avatar
    Join Date
    Dec 2006
    Location
    WATERWORLD
    Posts
    469
    +1
    1
    TTT

  6. #6
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by ERICG1 View Post
    Thats exactly what i think happened. I think the f***** front plastic cone came off !! What the hell do i do ???????????????????
    Like I said if that is the case it should have been almost impossible to get c clip on. ? Was that the case?
    If this is your problem, you need to remove drive shaft and see if it come out on shaft. IF it doesnt, you have to get it out and if not damaged then put back on and try again. IF is damaged from being out of postion then you need a new one. You can that part pretty easy.

  7. #7
    ERICG1's Avatar
    Join Date
    Dec 2006
    Location
    WATERWORLD
    Posts
    469
    +1
    1
    No i never had the circlip out

  8. #8
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by ERICG1 View Post
    Thats exactly what i think happened. I think the f***** front plastic cone came off !! What the hell do i do ???????????????????
    Firstly... calm down, pop open a beer... then pull out your shaft and examine it ...

  9. #9
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by ERICG1 View Post
    No i never had the circlip out
    IF you never had drive shaft out or C clip removed then that is not your problem. I think it would almost be imposible, for the cap to come off end of shaft without removing c clip and shaft sliding back. I may be wrong but i think you would need more slack then what the you get just removing pump.

    ANyone ever had a cap come off in this manor.

  10. #10
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by bigdaddyRXP View Post
    Pull the shaft and have a look! What led up to this... you say you have the pump off... what seal won't seat up

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Buying RXP tomorrow need HELP FAST!
    By transhow in forum 4-Tec Performance
    Replies: 19
    Last Post: 12-31-2008, 10:26 PM
  2. SuperCharger removal - Need help fast
    By seadawg in forum 4-Tec Performance
    Replies: 23
    Last Post: 11-06-2008, 08:55 PM
  3. Need Help Fast
    By yami_rida#26 in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 05-10-2008, 07:59 PM
  4. broken mfd need help fast
    By slpolaris in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-18-2007, 08:47 AM
  5. Wear ring ? need help fast!!!!
    By NeverEndn in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-08-2006, 01:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •