Results 1 to 5 of 5
  1. #1
    sl 1050
    Join Date
    Jul 2007
    Location
    Western Missouri
    Posts
    6

    need help with 94 750 ss/xi

    I have recently purchased a 1994 kawi 750ss/xi. The person I bought it from says it will run good for about 20 min then it will only run at about 1/2 throttle. If you give it any more gas it will bog down. He says it takes about 2hrs of cool down then it will run good again for about 20min. It is pumping water & the carbs have supposebly been rebuilt. I would appreciate any suggestions of what might be causing this problem & any maintenance tips & things to watch for on this particular ski.


  2. #2
    cigarlust's Avatar
    Join Date
    Apr 2008
    Location
    Funky town (Fort Worth TX)
    Posts
    1,171
    +1
    2
    There's a one way valve on the fuel line, I had an old 92 SS and it was doing the same thing... replaced it and it ran like a champ.

  3. #3
    sl 1050
    Join Date
    Jul 2007
    Location
    Western Missouri
    Posts
    6
    thanks cigarlust, would this be what the parts diagram calls a relief valve, its between the top of the fuel tank & the fuel filter

  4. #4
    I would check for an exhaust leak. Ride it till it dies and take the seat off to see if there is smoke in the hull.

  5. #5
    Pain is fear leaving your body.... rlovebk's Avatar
    Join Date
    Aug 2008
    Location
    So. Cal.
    Posts
    5,206
    +1
    511
    Pull the fuel pick-up out of the tank and inspect that also. Many times the holes for the return and vents are plugged and it'll be a mess. I have a '92 SS and this was a problem with it. It kept plugging up the fuel filter and would run abit then die. I am going to clean my tank out this winter. But after fixing pick-up problem it has ran good all summer.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with 750 ss xi
    By toddwooden in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-22-2013, 06:18 PM
  2. Need help with 96 750 sts, very lost.
    By Skippy The Skipper in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-17-2013, 05:16 PM
  3. Need Help with a polaris SL 750 issue
    By pdarling20 in forum Polaris PWC Performance
    Replies: 4
    Last Post: 06-11-2012, 08:25 AM
  4. Newb with 96' 750 ss xi - Thanks guys!!
    By ama009 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 04-26-2012, 02:15 PM
  5. need help with 1994 SL 750
    By Monkeyass in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-29-2011, 05:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •