Results 1 to 8 of 8
  1. #1

    Join Date
    Jan 2009
    Location
    Chicago & New Buffalo, MI
    Posts
    53

    Proper way to start the GTX is or RTX is ???

    I have had my GTX is for about a month now and have ridden it 4 or 5 times. I still can't figure out the right way to start it.

    4 different ways it starts/doesn't start.....

    1. Push and hold start button for 2-3 seconds and it starts right up
    2. Push start button gauges go on but no engine. then a beep beep comes about 10 seconds later. Hit start again and the engine turns on.
    3. Push start button engine turns on. 1 beep. No engine power.
    4. Push start button. Guages turn on. No beeps. No engine power.


    So what am I doing wrong? Most of the time #4 happens and I have to just keep unplugging the safety power cord and replugging it and trying over and over till option #2 happens.

    Please help thanks!


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Have you checked that the battery is fully charged (1-2 amp charger only), to the full mark of electrolyte, that the battery cables are tight, and the ground cables are tight too?... Ron

  3. #3
    brad_720's Avatar
    Join Date
    Sep 2008
    Location
    Dallas
    Posts
    65
    I had similar problems one day on the lake and discovered what looked like small metal filings inside the "key". It looked like black dirt, but was certainly metal of some sort.
    Just a thought.

  4. #4

    Join Date
    Jan 2009
    Location
    Chicago & New Buffalo, MI
    Posts
    53
    I haven't checked the cables but i have looked at the key and it looks clean.

    I think there is just a certain sequence I just don't know it.

  5. #5
    Your key is not on properly when it does not start or starts with no power, if you press the start button before installing the key you will get 2 beeps when the key is installed and it will start! Its a wierd system!

  6. #6
    jkflow's Avatar
    Join Date
    Jun 2007
    Location
    Tampa, FL
    Posts
    77
    +1
    4
    Quote Originally Posted by ChitownSeadoo View Post
    I have had my GTX is for about a month now and have ridden it 4 or 5 times. I still can't figure out the right way to start it.

    4 different ways it starts/doesn't start.....

    1. Push and hold start button for 2-3 seconds and it starts right up
    2. Push start button gauges go on but no engine. then a beep beep comes about 10 seconds later. Hit start again and the engine turns on.
    3. Push start button engine turns on. 1 beep. No engine power.
    4. Push start button. Guages turn on. No beeps. No engine power.


    So what am I doing wrong? Most of the time #4 happens and I have to just keep unplugging the safety power cord and replugging it and trying over and over till option #2 happens.

    Please help thanks!
    The iS acts differently than any other ski.
    Everything you stated appears to be normal which might be confusing at first.

    The proper sequence is (#2):
    1. Install key -> NOTHING happens!
    2. Push start key once -> gauges go through selftest etc and it ends with the typical beep-beep for an 'all ok and right key installed' ~30s total
    3. Push start again and engine starts up-> ride on



    The other modes:
    Install key, (that's your #1) you push and hold the start button 2-3s and engine starts up right away. No beeps if i recall this right. It's nice to do this when you are pressed for time at the dock or wherever. The gauges go through self-test etc while you are already on your way.

    Key installed and 1 beep (#3). Key was installed wrong (to slow, dirty etc.) remove, clean and replace key for the beep-beep (see above).

    No key installed (#4), you push start and the gauges come up for a self-check and turn off again. Can't start the engine.

    As you can see, all these are normal modes. Enjoy

  7. #7
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Quote Originally Posted by jkflow View Post
    The iS acts differently than any other ski.
    Everything you stated appears to be normal which might be confusing at first.

    The proper sequence is (#2):
    1. Install key -> NOTHING happens!
    2. Push start key once -> gauges go through selftest etc and it ends with the typical beep-beep for an 'all ok and right key installed' ~30s total
    3. Push start again and engine starts up-> ride on
    So you are saying that it takes over 30 seconds to start an IS? That is really handy to know in case a 50000 lb 56' Sea Ray Sedan Bridge is bearing down on you and can't see you from the bridge... Ron

  8. #8
    jkflow's Avatar
    Join Date
    Jun 2007
    Location
    Tampa, FL
    Posts
    77
    +1
    4

    Talking

    Quote Originally Posted by King_Of_Fun View Post
    So you are saying that it takes over 30 seconds to start an IS? That is really handy to know in case a 50000 lb 56' Sea Ray Sedan Bridge is bearing down on you and can't see you from the bridge... Ron
    No, but even if that's still ok. As strong, bulky and heavy and whatnot the iS hull is built, the SeaRay will only scratch the surface of my paint while it will sink with a 11 ft hole in its hull.

    Actually you can start this faster than a regular ski or just as fast. Key on, push start and you are gone. I doubt you are interested in the self-test and 'Welcome aboard' message when the mentioned SeaRay is heading your way...but you have the option to wait for the beep-beep

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Proper way to start up a 2000 kawasaki ultra 150
    By MrPirate23 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 07-06-2012, 01:19 PM
  2. Bad Way to Start the Day
    By Monkeytunk in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 06-28-2012, 01:58 PM
  3. what is the best way to change the colour of my ski?
    By balbaa in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 10-24-2007, 09:11 PM
  4. what is the best way to change the colour of my ski?
    By balbaa in forum 4-Tec Performance
    Replies: 0
    Last Post: 10-24-2007, 01:29 PM
  5. What is the proper way to convert to premix on a 97xp?
    By Satanklawz in forum 2-Stroke Performance
    Replies: 30
    Last Post: 07-14-2007, 09:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •