Results 1 to 3 of 3

Thread: Speedo problems

  1. #1

    Join Date
    Jul 2009
    Swampland Louisisana

    Speedo problems

    02 RXDI the speedo quit, will not register anything.
    Every now and then only at WOT will it flash on for a 1/2 second or so.

    The paddlewheel is intact and spins freely, is there a way to test the system?


  2. #2

    Join Date
    Jul 2009
    Chester Va

    speed sensor testing

    I had the same trouble with 98 GSXL, i did a google search & found troubleshooting online, mine was the speed sensor

    David N

  3. #3

    Join Date
    Jul 2009
    Swampland Louisisana
    Any ideas guys?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. speedo problem on 2001 RX
    By jetmanjay in forum 2-Stroke Performance
    Replies: 0
    Last Post: 09-25-2010, 08:00 AM
  2. STX 15F Speedo problem
    By larryhood in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 07-29-2009, 02:07 PM
  3. Help a Girl out? Speedo problem?
    By Skygazer in forum Yamaha Open Discussion
    Replies: 18
    Last Post: 07-22-2009, 06:46 PM
  4. Ultra 250x Speedo Problems
    By UltraRider314 in forum Kawasaki How To & FAQs
    Replies: 3
    Last Post: 07-28-2007, 07:02 PM
  5. Speedo Problem
    By scorp in forum Polaris Open Discussion
    Replies: 4
    Last Post: 01-20-2007, 12:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts