Results 1 to 7 of 7
  1. #1
    dpoole5074's Avatar
    Join Date
    Aug 2008
    Location
    Scottsbluff
    Posts
    115

    Arrow High Idle??? HELP

    Just installed Riva IC and 50 injectors and now my idle is around 2600 rpm sitting on trailer...turned down the idle as far as I can but does not affect the idle...please help I wanna take it out tomorrow but it has me a little worried....thanks


  2. #2
    Golden Jet red fox's Avatar
    Join Date
    Dec 2008
    Location
    DiJeddah
    Posts
    322
    Quote Originally Posted by dpoole5074 View Post
    Just installed Riva IC and 50 injectors and now my idle is around 2600 rpm sitting on trailer...turned down the idle as far as I can but does not affect the idle...please help I wanna take it out tomorrow but it has me a little worried....thanks
    1st Check the block off ( the nuts ) looking for the leak

  3. #3
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    To be revving that high sounds like you have a pressure leak somewhere. Retrace your steps. Something still loose possibly? Exhaust coupler? Hose from s/c to i/c? Did you take the intake manifold off to get the old innercooler out? If so, this is likely the problem. The bottom of the intake manifold must be pressed in first; then the top portion get pressed in where the torx screws are located. (near the fuel rail)

    Just some ideas........


    Brendan

  4. #4
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Make sure the throttle cable is not bound up anywhere and make sure it the throttle plate is hitting the stop.

  5. #5
    dpoole5074's Avatar
    Join Date
    Aug 2008
    Location
    Scottsbluff
    Posts
    115
    thanks for the reply's guys...double checked everything and the fitting for the boost gauge off the block off was not on....place it on and now is idling at around 1700...is that about where it should be or what is the ideal rpm at idling...thanks again guy's...

  6. #6
    Golden Jet red fox's Avatar
    Join Date
    Dec 2008
    Location
    DiJeddah
    Posts
    322
    Quote Originally Posted by dpoole5074 View Post
    thanks for the reply's guys...double checked everything and the fitting for the boost gauge off the block off was not on....place it on and now is idling at around 1700...is that about where it should be or what is the ideal rpm at idling...thanks again guy's...
    100%

  7. #7

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    1700 or 1850 is the norm

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. twin 800 challenger high idle help
    By JonnyRXT in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-23-2011, 05:51 PM
  2. High Idle!!!! Please Help!!!!
    By dsmcrazy79 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-18-2008, 08:35 AM
  3. High Idle Speed HELP
    By pakalot in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-14-2008, 11:01 PM
  4. 2006 STX 12F Idles too high. please help
    By Doutney1225 in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 08-09-2007, 03:11 PM
  5. 2006 STX 12F Idles too high. please help
    By Doutney1225 in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 08-09-2007, 11:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •