Results 1 to 7 of 7
  1. #1
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673

    Innovate LM-2 Users

    For those of you using the LM-2... you may or may not be having issues with crazy readings due to improperly loaded firmware. I bought my LM-2 four or five months ago and it never functioned properly, it was showing me very lean readings that I knew were not accurate... then when I tried it for the second time it would act as if the 02 sensor was not even connected... wouldn't calibrate... nothing... WTF Attached is a link to the latest updated v1.13 firmware... this update cured all my issues Check your LM-2 manual for firmware installation instructions... I've also attached the user manual in PDF format as well

    http://www.innovatemotorsports.com/support.php
    Attached Files Attached Files


  2. #2
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,134
    +1
    821
    Hmmm, wonder who told you about this fix?
    Thanks for letting me us it and for your help. Actually we have Mark to thank. He is the one that figured it out. Thanks Mark.

  3. #3
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by Gus13letter View Post
    Hmmm, wonder who told you about this fix?
    Thanks for letting me us it and for your help. Actually we have Mark to thank. He is the one that figured it out. Thanks Mark.
    +1... Just passing along the info

  4. #4
    ctriverguy's Avatar
    Join Date
    Aug 2007
    Location
    Ipswich, Massachusetts, United States
    Posts
    1,509
    +1
    8
    thanks guys... bought the lm2 when it came but just going to be using it for the first time tomorrow..

  5. #5
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,992
    +1
    455
    And I thought all 6 of my o2 sensors were fuk'd up. Thanks for the update!

  6. #6
    ctriverguy's Avatar
    Join Date
    Aug 2007
    Location
    Ipswich, Massachusetts, United States
    Posts
    1,509
    +1
    8
    Another FYI for turbos

    (cut and paste from the lm-2 manual)

    The maximum temperature of the sensor at the bung (the sensor hexagon)
    should not exceed 500
    oC or 900 oF. If these temperatures are exceeded in your
    application you should either install a double length bung (one inch) or the Innovate
    Motorsports Heat-Sink Bung extender (HBX-1).

    The double length bung is also recommended for situations where airflow is restricted.

    I idled at 1200,lol and hit and one point hit 1800.

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by ctriverguy View Post
    Another FYI for turbos

    (cut and paste from the lm-2 manual)

    The maximum temperature of the sensor at the bung (the sensor hexagon)
    should not exceed 500 oC or 900 oF. If these temperatures are exceeded in your
    application you should either install a double length bung (one inch) or the Innovate
    Motorsports Heat-Sink Bung extender (HBX-1).
    The double length bung is also recommended for situations where airflow is restricted.

    I idled at 1200,lol and hit and one point hit 1800.
    THat is one of the problems keeping the sensor from going to toast.
    I ran a heat sink and it seemed to help, but cant really say for sure except I had one sensor last thru alot of time.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_3605.jpg 
Views:	104 
Size:	1.03 MB 
ID:	142861  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS Innovate LM- not working for parts & cables
    By vxrpete8 in forum General Classifieds
    Replies: 3
    Last Post: 01-01-2011, 02:27 PM
  2. Innovate LM-2
    By maxadrenaline in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 12-05-2010, 08:15 PM
  3. FS Innovative LM-2 Wideband A/F ratio logger/reader +EXTRAS
    By BPnta in forum General Classifieds
    Replies: 1
    Last Post: 01-20-2010, 09:56 AM
  4. WTB: Innovate LM-1
    By VX1 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 05-31-2008, 12:02 PM
  5. New Innovate LM-2
    By aha in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-14-2008, 07:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •