Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

Thread: RXP speeds...

  1. #1
    dpoole5074's Avatar
    Join Date
    Aug 2008
    Location
    Scottsbluff
    Posts
    115

    Exclamation RXP speeds...

    Just tried out my ski with the new intercooler and injectors and am very displeased with the results...for that money I thought I would see dramatic results but was only running around 7200 rpms and have no bottom end...was looking for some ideas to try and see where my power is going. Seems I should be runnin way faster than it feels...any ideas where to start...maybe it just needs to be tuned in correctly but around here the sea doo dealer won't even work on mine cause of the mods so I am kinda wingin it here with help from you all....


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Check all your couplers for boost leaks.....

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by dpoole5074 View Post
    Just tried out my ski with the new intercooler and injectors and am very displeased with the results...for that money I thought I would see dramatic results but was only running around 7200 rpms and have no bottom end...was looking for some ideas to try and see where my power is going. Seems I should be runnin way faster than it feels...any ideas where to start...maybe it just needs to be tuned in correctly but around here the sea doo dealer won't even work on mine cause of the mods so I am kinda wingin it here with help from you all....

    What were your RPMs before the new mods? Did u try an 83mm ring?

  4. #4
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    ya dude, somethin is WAY off, what were previous stats, and what did you take apart/put together since then???
    i also agree boost leak somewhere, possibly exhaust leak?
    water routed wrong to IC?
    SC gear slipping?

  5. #5
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,322
    +1
    635
    Do you have a stock ecu ? cause x charge w 50's injectors I think is to big. unless you left out you have a riva ecu. Fresh or saltwater air temp and water temp?

  6. #6
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by Treemn View Post
    Do you have a stock ecu ? cause x charge w 50's injectors I think is to big. unless you left out you have a riva ecu. Fresh or saltwater air temp and water temp?
    +1. Your way rich with those 50s. You need 42s with that set-up and also you will need to go to a bigger nozzle. You should be close to 8100rpms with that set-up and an 83mm nozzle but you really need to get your A/F dialed in..

  7. #7
    dpoole5074's Avatar
    Join Date
    Aug 2008
    Location
    Scottsbluff
    Posts
    115
    running stock ecu..had an 83 ring in and changed out to an 81...had 42 injectors in and jerry said go with the 50's....on the IC I have the inlet on top and outlet on bottom...before mods I had 42's a 14/19 and stock IC and was at 8100 rpm's..today when we pulled out drain plugs it took about 5 min to drain and water was very hot...know I have a leak somewhere...temp was about 91 and lake was about 74 and engine was running 84-86....what is the best a/f product to buy..thanks again guys

  8. #8
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    50s are too much by themselves, let alone a RRFPR on top of it all. E temp on the dash is outside temperature. If your engine was running at 84-86 degrees you'd be in serious trouble. Innovative LM-1 seems to do the trick for most people dialing in AFR.

  9. #9
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Fix your water leak first. If everything is not perfect, you are just wasting gas and time.

  10. #10
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,248
    +1
    62
    Quote Originally Posted by dpoole5074 View Post
    running stock ecu..had an 83 ring in and changed out to an 81...had 42 injectors in and jerry said go with the 50's....on the IC I have the inlet on top and outlet on bottom...before mods I had 42's a 14/19 and stock IC and was at 8100 rpm's..today when we pulled out drain plugs it took about 5 min to drain and water was very hot...know I have a leak somewhere...temp was about 91 and lake was about 74 and engine was running 84-86....what is the best a/f product to buy..thanks again guys
    Ok go back to 42's and 15/20 you will be fine! if you engine was running 84-86 then you have openloop plate!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP speed/pump ideas
    By Vern in forum 4-Tec Performance
    Replies: 93
    Last Post: 12-20-2011, 05:17 PM
  2. RXP speeds vs rpm and impeller pitch
    By Vern in forum 4-Tec Performance
    Replies: 21
    Last Post: 02-10-2007, 11:35 PM
  3. Stage I ++ 06 RXP speed 77.8 mph
    By Hypertoys in forum 4-Tec Performance
    Replies: 28
    Last Post: 08-22-2006, 11:43 AM
  4. RXP Speeds
    By oklagp1200r in forum 4-Tec Performance
    Replies: 15
    Last Post: 07-25-2006, 09:17 PM
  5. MY RXP Speed
    By oklagp1200r in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-27-2006, 10:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •