Results 1 to 2 of 2
  1. #1

    Polaris SL 750 Electrical Help??

    I just got a "95 Polaris Sl 750 that seems to run great. I'm new to the jet ski world and really love this thing. After having it on the water this weekend, everything seemed to be in good shape other than the MFD is not working or the Trim. I have been looking at other posts here and have checked the fuse in the electrical box and thats about it. Any ideas where to start and get this troubleshooted in the right direction?

  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    The trim motors get a bit rusty and seize up. They can be saved if you break them free and lube them up.

    First put 12V to the motor first to see if that is the problem.

    On the MFD, try unplugging it and plugging it back in, hard. Sometimes the connection is poor.

    If that doesn't work try the reset procedure found in the tech section.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hi Folks, Need s a little help on Polaris slt 750 electrical issue
    By Mattwnh in forum Polaris Tech Tips and Info
    Replies: 3
    Last Post: 07-16-2013, 08:20 PM
  2. 1995 Polaris sl 750 electrical help
    By chrisahuddleston in forum Polaris Open Discussion
    Replies: 1
    Last Post: 10-03-2012, 07:24 PM
  3. Polaris SL 750 Electrical Help
    By tom oswald in forum Polaris Open Discussion
    Replies: 21
    Last Post: 07-23-2009, 09:02 PM
  4. Polaris SL 750 Electrical Help??
    By tom oswald in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-22-2009, 06:04 PM
  5. 1995 Polaris SL 750, please help
    By 750slt in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-30-2009, 02:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts