Results 1 to 2 of 2
  1. #1

    virage txi backfires

    I have a 02 polaris txi 1200 DI. It just backfires thru the exhaust and blows apart the resernators and does not run .I have check the crank to see if it's out phase-ok. I have taken apart the stator/flywheel cover. all look in great cond. magnets tight keyway not slipped.The local dealer said it's the emm and theire is not a test just replace.Way to much $$ to just throw parts at it.any help would be great.

  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    The EMM can be repaired.

    Contact DFI Technologies, details in the links below.

    Check the CPS, but I expect it is indeed the EMM which has failed.

    The ignition and injector wires have not been moved around, have they?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris Virage 1200 TXI Backfires
    By gleathem in forum Polaris Open Discussion
    Replies: 12
    Last Post: 06-15-2011, 09:40 PM
  2. Polaris Virage TXi 2002 - Backfire, EMM codes 12 & 17
    By JENNAANDRICK in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-09-2011, 02:50 PM
  3. 02 Virage TXi Backfire
    By sammer77 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-07-2007, 04:30 PM
  4. Virage txi Giving me trouble
    By Mauivirager in forum Polaris How To & FAQs
    Replies: 21
    Last Post: 12-19-2006, 06:21 PM
  5. virage txi help
    By superduty in forum Polaris PWC Performance
    Replies: 4
    Last Post: 09-11-2006, 04:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts