Page 1 of 13 1 2 3 11 ... LastLast
Results 1 to 10 of 126
  1. #1

    Looking for some help with 96xp tuning and troubleshooting

    I have a 96 xp i have been building and riding for a few years. About 2 years ago i put a new top end in it with WSM platinum pistons. After a few hours of riding i seized the PTO piston. Pulled the carbs and found a clogged filter, typical. Honed the cylinder, replaced that piston, and it lasted approx 20 hrs.

    I have the timing advanced 1deg, group K head with .050 squish, 170psi comp. Jetting is 75ls, 150hs with flame arrestors.

    After pulling the cylinders again a few weeks ago, and finding no issues, i put another piston in it, and ran it. I broke the piston in, then began to hammer it, it held 7150 for a good few mins. About and hour later, it seized once again. The MAG piston has approx 45 hrs on it, and is in great shape. I am trying to figure out why just the PTO piston keeps seizing. There is alot of oil inside the motor that doesn't seem normal. It is premix, and is currently holding 5psi in the RV cavity test. I have a feeling the motor may be creating too much heat, but not sure of that. Below are some pics that i just took of what is going on. Looking for some suggestions.

    PTO piston


    Oil on pistons






  2. #2
    Here is a pic of how much oil is sitting in the MAG exhaust port, PTO was the same. It is black nasty oil. RV has been holding 5psi for 15 mins. I run Amsoil interceptor @ 45-1


  3. #3
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Mark, did you pressure test the engine yet to see if the rear crank seal is leaking?

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    that just doesnt make sense strange

  5. #5
    I didn't, i don't have a kit. I ordered a kit this am from Watcon. I am confident it is not a leaking seal, but i guess i will not know for sure until i test it. If it were a leaking seal, wouldn't i notice it on the PTO plug? Or some other sign that cylinder was leaning out?

    Is there a better way to cool this motor? Is my tight squish, higher compression, and timing causing too much heat? But why just the PTO. Why the nasty, smelly oil in both cylinders? GRRRRRRRRRR

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    After confirming no air leaks, it could just be the cheap WSM pistons can't handle the heat.

  7. #7
    Quote Originally Posted by 96XPSS View Post
    After confirming no air leaks, it could just be the cheap WSM pistons can't handle the heat.

    I bought a set of Pro-x, and shipped them out with a spare set of cylinder i had to be bored with .006 clearance. They should be here today or tomorrow, but i do not want to assemble this motor until i figure this out. Pistons are getting exspensive!!!

    Would i benefit from reverse cooling it?

  8. #8
    The RV cavity held 5psi for an hour with no drop.

  9. #9
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    An air leak should be visible by the spark plug color. But...repeated piston failures when you know it isn't fuel...pretty much indicates an air leak.

  10. #10
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Oil film is normal. Heat? Confirm the outlet restrictor in the transom is not partially clogged with debris.

Page 1 of 13 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to this forum and was looking for some help on a 2004 KAWASAKI STK-12F
    By jcard71 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 03-23-2015, 07:38 AM
  2. Looking for some help on plastic intake manifold repair
    By frogurt in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-08-2013, 07:16 AM
  3. NOT a pwc.. a mercrusier BUT im hoping for some help with this plug!
    By jayp0209 in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 05-13-2012, 06:15 AM
  4. Looking for some help on finding a STX 15F
    By skigirl1 in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 04-07-2010, 04:41 PM
  5. looking for some info about vts rod and wedge kit
    By sfackett0 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-23-2008, 09:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •