Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843

    S/C IMP & BOV INSTALLED

    Thats all I have to say about the acceleration of my ski now .. I can no longer mash it outta the hole it will come out the water and gop no where i actually had to feather it out in a way then mash it .. the acceleration is SICK !!!!! I have only one concearn .. my top speed today was 62.6 now it was extremly windy and very choppy .. so im hoping that is what casued the low speeds i would think IF something was wrong with the BOV or the imp it would not have that type of acceleration ..IM HOPING!!!! I wont know until the storm passes and i can get it out on some flatter water . I just didnt think i could loose 8 mph from heavy chop!


  2. #2
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    Sickening isn't it that the conditions are always gloomy when your spirit is sunny (insert cheesy Tele Tubbie pic here).

    That's aspiring news about the acceleration and seems to support every other post on this mod.

    I know I will head in that direction sooner than later. I'm still waiting for the skies to clear up to test the exhaust mods and venturi...damn fishermen!

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,976
    +1
    1,895
    Chris, thats great news bro! You were crying over nothing! I TOLD you that it made a great deal of difference in your acceleration. Trust me next time

    and YES! you can easily lose 8 MPH in rough conditions.

  4. #4
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    jerry!!!! 8 mph !!! RX4pain .. If i had to do all my mods over .. no doubt the s/c impellar would be 1st!!! I am extremly impressed with the acceleration .. yes i am worried about 62 mph top speeds but then agian i was unable to keep the boat in the water .. i though i was going to seearound 66 67 .. not 62 i didnt think u could loose that much mph from chop esc seeing i have a grate ...

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,976
    +1
    1,895
    dude, sometimes even having a grate won't help you. if you cant keep it hooked up you cant make speed.

    gotta love that acceleration though huh?

  6. #6
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    jerry ... i dont know i waited this long thats all i have to say about thaaaaaaaaaaat

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,976
    +1
    1,895
    i dont know why you waited that long either... i been trying to tell ya

  8. #8
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    Chris - keep me up to date on this thread about your speed when conditions improve.

    Chris (rx4pain)

  9. #9
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    I love my Riva grate, but even yesterday I couldn't stay hooked up.

  10. #10
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    I hear ya jer... Chris sounds good hopefully sometime next week it will be nice enough to find some glass somewhere . IM dieng to get out and ride .. summer cant come quick enough now!!! water is like ice still!!!!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bov instal problem plz help:(
    By Rxp270hp in forum 4-Tec Performance
    Replies: 11
    Last Post: 11-11-2011, 09:16 PM
  2. BOV Install
    By Azone in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 11-28-2010, 09:17 PM
  3. Greddy BOV Install on R&D Intercooler
    By washingtonrider in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 09-26-2010, 05:17 PM
  4. BOV installed
    By onebadsho in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 06-09-2009, 07:24 PM
  5. BOV install
    By Kinchyle in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-16-2006, 05:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •