Results 1 to 2 of 2

Thread: 96 sl 900

  1. #1

    96 sl 900

    hi i need help with a 96 sl 900 it idels fine, revs good on trailer, but wont run but about 10 mph in the water ride plate has several stripped bolts got parts coming to fix anybody got the cure thanks steve


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    If this is the same ski, let's keep all the posts in the same thread.

    Did you do the checks suggested in that thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Have a few ??'s about a recently purchased 96 sl-900
    By gvnitup in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-11-2007, 09:46 AM
  2. Is a 96 sl-900 worth 550 ?? Top-speed???
    By gvnitup in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-07-2007, 06:29 PM
  3. 96 sl 900
    By mixedguy in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-08-2007, 05:38 PM
  4. Where can I get a deal on parts for a 96 SL 900???
    By Alberta Boy in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-18-2007, 01:25 PM
  5. 96 SL 900 CDI and stator
    By S12L00X in forum Polaris PWC Performance
    Replies: 0
    Last Post: 03-13-2007, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •