Results 1 to 6 of 6
  1. #1
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373

    NEWBIE questions...please help

    Hey guys,
    06 RXP no mods but a 15/20 impeller installed.(guy I bought it from chewed up the stocker)will be changing it out soon, and wear ring is brand new. I am only getting 7400 rpms max. Would the impeller drop the r's this much or do you think my S/C is slipping? Acceleration up to 7400 is great and I can hear the whine heading up there. Also, did an oil change when I got home per instructions here, it seems that I sucked out closer to 4 qts BUT the dipstick did not show overfilled. Can it be overfilled and not show it? I put in 3 qts and now it is right at the bottom mark. Should I leave it there or add more.
    (06 washers have been ordered) Thanks in advance! Steve


  2. #2
    RustySeaRustyDoo's Avatar
    Join Date
    Oct 2005
    Location
    Chesapeake Bay-Pasadena, MD
    Posts
    1,788
    I would say that 15/20 is too much for stock if Im not mistaken. Its def scrubbing rpms.

  3. #3
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    You say you have a 15/20 fitted that alone will lose the rpms.Get a 14/19 and a repitch.Oil sould be between the the two bends i would add a little.

    Hope this helps Rob

  4. #4
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    thanks guys. I am hoping it is the prop and not the S/C slipping. I want to ride it until I get my washers and new prop put in. I just dont want to be rolling the dice with anything.

  5. #5

    Join Date
    Apr 2005
    Location
    Elysian Fields,Tx
    Posts
    358
    It's the prop Steve,too much pitch for stock.Add just a little oil and your good to go until you get the prop changed.

  6. #6
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Thanks UFO!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 slt 750 Newbie Questions!! Please help!!
    By MadCatter in forum Polaris Projects
    Replies: 2
    Last Post: 07-22-2015, 08:09 AM
  2. Compressor Surge Question...Please Help!
    By left coast girl in forum 4-Tec Performance
    Replies: 8
    Last Post: 10-23-2007, 11:50 AM
  3. question please help..
    By GameDemon in forum Polaris Open Discussion
    Replies: 15
    Last Post: 06-22-2007, 11:30 AM
  4. Couple of questions please help...
    By OzVirage in forum Polaris Open Discussion
    Replies: 6
    Last Post: 02-12-2007, 08:39 PM
  5. Supercharger Impellar Upgrade Question? please help
    By NeverEndn in forum 4-Tec Performance
    Replies: 42
    Last Post: 01-12-2007, 01:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •