Results 1 to 2 of 2

Thread: 96 sl 900

  1. #1

    96 sl 900

    hi guys did a compression check #1 120 #2 118 #3 120 that was with my guage i use on my car ? it looks like some one has put a new oil pump on. could it be oiling to much & cause it not rev in water? it smokes alot even at idle thanks steve


  2. #2
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    1,975
    +1
    34
    Mine smokes a lot too at idle....I doubt that would cause you to run at such low RPM

    You should probably keep your issue confined to a single thread instead of different threads.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Have a few ??'s about a recently purchased 96 sl-900
    By gvnitup in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-11-2007, 09:46 AM
  2. Is a 96 sl-900 worth 550 ?? Top-speed???
    By gvnitup in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-07-2007, 06:29 PM
  3. 96 sl 900
    By mixedguy in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-08-2007, 05:38 PM
  4. Where can I get a deal on parts for a 96 SL 900???
    By Alberta Boy in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-18-2007, 01:25 PM
  5. 96 SL 900 CDI and stator
    By S12L00X in forum Polaris PWC Performance
    Replies: 0
    Last Post: 03-13-2007, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •