Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    rxpx just blew up !!!

    was out today ,noticed it started badly a few times but then was ok ,then all of a sudden the throttle lagged for a sec then bang !!! then nothing wouldnt even turn over , thought id hit something it was so loud ,looked inside was a bit of smoke ,engine was well hot and no more coolent in the bottle aprt from that nothing to see , anyone got ideas ,ski is 1 year old 180 hours and had complete sc rebuild at 100 hr service


  2. #2
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    Sounds like a rod went. Did you ever ingest water. Ever? Loud bang and no coolant? I bet you have a hole in the side of your cases.

  3. #3
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Wow, sounds serious...

  4. #4
    Never say never KirkF350's Avatar
    Join Date
    Jun 2005
    Location
    Midlothian, Texas
    Posts
    4,433
    +1
    3
    Damit!

  5. #5
    rxpstage2+ rw40426's Avatar
    Join Date
    Dec 2007
    Location
    sc
    Posts
    76
    I purchased my 07 rxp brand new and it dropped a valve in the first dam 30 min. on the water. Took it back to dealer and was down for 2 1/2 months.

  6. #6
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    ouch, hopefully there is still warranty left

  7. #7
    Faster Than a Snail on a Log mongorunner's Avatar
    Join Date
    Jun 2007
    Location
    North of Amarillo TX
    Posts
    741
    wow 180hrs


    i don't think ill ever ride that much ever


    sorry bout your luck, you still have it under warranty?

  8. #8

    Join Date
    Sep 2006
    Location
    Jersey British Isles
    Posts
    2
    Hmm sounds interesting, best you take it to your local top tech and get it sorted. Don't worry he will look after you
    Sounds like he will be busy monday!!

  9. #9
    Rampage's Avatar
    Join Date
    Sep 2007
    Location
    Holland, Michigan, United States
    Posts
    2,932
    180 hours shouldnt be a factor should it? Its not that many

  10. #10
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by Rampage View Post
    180 hours shouldnt be a factor should it? Its not that many

    He had 80 hrs on the rebuilt charger.....that is quite a bit. Some last 100 hrs, some not as many. It was about time for a second rebuild also it sounds like. Pull the charger, and check if the motor will spin over after. If the charger is good, then blown head gasket,or worse(blown rod) and hydro locked the motor. Pull the plugs to see if coolant comes out the holes.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 RXT just blew up
    By dave262626 in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-27-2016, 08:38 PM
  2. Just picked up a 2012 RXPX
    By Murderski in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-15-2015, 10:29 AM
  3. Just blew up the SLl 700
    By friscoboater in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-27-2010, 07:19 PM
  4. Lake Keowee, SC- just picked up a RXPX
    By JPBabyRange in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 03-23-2010, 03:05 PM
  5. Just Blew My RXP Up!!
    By rick xp in forum 4-Tec Performance
    Replies: 25
    Last Post: 07-22-2008, 04:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •