Results 1 to 4 of 4
  1. #1
    FrankieV123's Avatar
    Join Date
    Aug 2008
    Location
    Florida -JERSEY
    Posts
    260
    +1
    1

    has anyone had this with a wear ring..

    wish i took a picture... the solas 15/22r shaved into it when i installed it in a new wear ring... looks like a step....----i__ like that kind of..smooth. like a 1 mm drop to where the blades are.. the blades are still very close but not touching the ring anymore.....any comments.. should i sand the ring to get rid of the step down?


  2. #2
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    That's normal. If it were a SS wear ring it would be eating the impeller instead.

  3. #3
    FrankieV123's Avatar
    Join Date
    Aug 2008
    Location
    Florida -JERSEY
    Posts
    260
    +1
    1
    yea i was thhinkin if i put in that SS wear ring...that would have been the end of my 300 dollar solas

  4. #4
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    The blades flex during acceleration & that mm flex is normal. The SS ring won't kill the prop right away, it actually erodes the center prop edges. You'll get better hook up & acceleration with it too. You should go with a solid front motor mount to if you go with a SS ring.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. So has anyone had issues with the new 300s & stuffing?
    By Phishphan1995 in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-12-2016, 11:53 PM
  2. Has anyone had any experience with this Mr Funnel product, water trap etc
    By rod_rod in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 08-24-2015, 06:23 PM
  3. Has anyone tried this: repair RAVE Valve with Aluminum tape?
    By Warren Hardguy in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-27-2010, 08:39 AM
  4. has anyone had any success with this part?
    By bblades262 in forum 4-Tec Performance
    Replies: 2
    Last Post: 03-29-2010, 05:53 PM
  5. has anyone had fun with there girl reverse??
    By Rodneyae in forum Polaris Open Discussion
    Replies: 8
    Last Post: 08-09-2007, 09:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •