Results 1 to 10 of 10
  1. #1

    Join Date
    May 2006
    Location
    Cincinnati
    Posts
    697
    +1
    3

    cavitation!!!! HELP!!

    ok, so I sucked up a stick 2 weekends ago. Got my riva stage one, installed itreplaced the wear ring because the stock one was trashed thanks to the stick. Anyways took ski out ran great... about 2hrs into it IT started to cavitate bad out of the hole. I t would just spin the prop.. you had to give it slow gas untill u were up but then it ran like a champ it was just out of the hole.

    pulled the pump tonight, nose cone is still on the new 14/19r. wear ring has some wear, but there are no gaps around the prop at all.. What could have caused this?? I did notice that the grease I put on the shaft spewed out a bit.. and there was water in were the noise cone is.. maybe the seal isn't that good like the old one?? But would this cause cavitiation??? some one mentioned carbon seal, but my ski only has 13 hrs on it, how do I know if thats bad???

    The seal around the pump looked good as well.
    could it maybe be the prop being loose?? althoug it ran great once on a plain..

    What could be causing this?? should I flip the wear ring to see if maybe it is that??


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    check for broken motor mounts,could cause the carbon seal to leak at launch.

  3. #3
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Either the damage to the wear ring is worse than you think, or the carbon seal is the problem. The water in your pump cone is unrelated because it is past the pump. But get that fixed or it will lead to big problems. Are you using the stock pump cone? Are the O-rings in place and undamaged?

  4. #4

    Join Date
    May 2006
    Location
    Cincinnati
    Posts
    697
    +1
    3
    broken motor mounts! man I hope not

  5. #5
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Yeah that would suck.

  6. #6
    carfanatic: is the neoprene seal folded over? pull the pump and check it...

    it`s ok for the greas to fly out of the nose cone, I just took mine off bc it kept coming off by itself even though it is only a few hours old, and when that happened it would cavatate out of the hole...but check to see if you folded over the seal...PR...

  7. #7

    Join Date
    May 2006
    Location
    Cincinnati
    Posts
    697
    +1
    3
    pale, you talkn about the rubber seal around the wear ring? that is fine I checked it. I have the pump out Idont see anything abnormal???

  8. #8

    Join Date
    Jun 2006
    Location
    Hidden Valley Lake, CA
    Posts
    28

    hey

    Hey did you take out the old nose cone from the other impeller. I forgot my old one slid up and never saw it and caused all sorts of cavitation. Pete
    just a thought

  9. #9

    Join Date
    May 2006
    Location
    Cincinnati
    Posts
    697
    +1
    3
    ya I did.

    do you guys think it could be the wear ring? I mean it wore some of it away.. there it groove in it from where the ring doesn't touch, to where it starts you can feel how its worn down?? its a brand new ring though???

  10. #10

    Join Date
    May 2006
    Location
    Cincinnati
    Posts
    697
    +1
    3
    anyone???

    could maybe the impeller not be right and eat the wear ring to quick? I had to kinda tap it in with a rubber mallet, to get it into the wear ring, but once it was in it spun fine.
    Last edited by CarFanatic; 08-04-2006 at 08:48 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FZS Cavitation help
    By afc in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 02-17-2010, 08:47 PM
  2. Cavitation??......Help!!!!!
    By Rip'nTear SHO in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 12-20-2008, 04:42 AM
  3. Cavitation help
    By douglasb76 in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 11-05-2008, 08:06 PM
  4. cavitation??? help !!
    By SHIFT in forum 4-Tec Performance
    Replies: 5
    Last Post: 03-03-2007, 09:08 AM
  5. Cavitation help
    By mattpm07 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 05-05-2006, 01:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •