Results 1 to 4 of 4

Thread: is this normal?

  1. #1

    is this normal?

    Went to launch today had seat off for no reason lowered ski noticed water in hull 1/2 inches could not see where it was coming from. started engine in N cleared is this normal? Did not ride brought home hosed everything no joy help

  2. #2
    Sorry RXT 07 thru hull, riva ic,gen 2 wheel, 42,opas bo etc.

  3. #3
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Jacksonville, Fl
    No, it's not normal. A little water is normal, like a few tablespoons full. You've got a leak somewhere...Loose hose clamp, hull drains not sealing, carbon ring leaking, etc.

  4. #4
    Not sure where to start looking nothing showed on hose down. Placed the ski in the water again water in no visable route? Stuck

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water upfront on my RXT/ this normal?
    By 2006 RXT in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-30-2007, 11:31 PM
  2. is this normal?
    By 07vette in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-04-2007, 12:08 AM
  3. Is this normal?!?!
    By Titanese in forum 4-Tec Performance
    Replies: 21
    Last Post: 06-30-2007, 07:43 AM
  4. Is this normal?
    By WildBill9000 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-10-2006, 03:36 PM
  5. Is this normal???? Plug not connected....?
    By GeoRXT in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-29-2006, 09:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts