Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    Join Date
    May 2006
    Location
    MIAMI
    Posts
    256
    +1
    1

    05 RXP STAGE 2 going to slow

    I installed today my riva intercooler and i only went 68 mph at 8100 rpms
    ..

    Does any one have any ideas what else i need or where my speed went..





    mods are 14/19
    r/d intake
    rear exhaust
    rd intake great
    riva intercooler


  2. #2

    Join Date
    Jun 2006
    Location
    Mobile, AL
    Posts
    75
    Did you pull out the stock IC?

  3. #3

    Slow Stage 2

    What prop are you running?

    Are you sure you don't have a boost leak? Can you connect an accurate boost gauge to test it?

  4. #4

    Join Date
    May 2006
    Location
    MIAMI
    Posts
    256
    +1
    1

    rxp

    14/19 prop

    yes i removed the stock intercooler...


    Maybe i need to check boost....

  5. #5
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    What speed were you at before? Where do you live? Lot of places have a heat wave right now, I don't care what you do, performance is going to be down when the water is like "bath water."

  6. #6

    Join Date
    May 2006
    Location
    MIAMI
    Posts
    256
    +1
    1

    stage two two slow

    i live in miami i never gps until put all mods on it was around 7;00 pm when i ran so it wasn't that hot besides most guys with these mods are running mid 70s

    well back to turning wrenches...

  7. #7
    GRNGOBLIN's Avatar
    Join Date
    Feb 2006
    Location
    LAKE OF THE OZARKS, MO
    Posts
    166
    do you have an up graded super charger wheel? if you have a complete stage 2 you are running the wrong prop ...ya need the 15/20

  8. #8

    Join Date
    May 2006
    Location
    MIAMI
    Posts
    256
    +1
    1

    rxp 2 slow

    no i don't have the supercharger wheel i ran a 15/20 also nd only went 65 mph at 7500 rpm

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Used intercooler? It could be clogged!

  10. #10
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,071
    +1
    790
    Quote Originally Posted by JOSE13RT
    no i don't have the supercharger wheel i ran a 15/20 also nd only went 65 mph at 7500 rpm
    It is not a STG II then. I would say try and clean your IC and go from there.
    With the Vortec SCer wheel and 15-20 it will put you in the 73 + range then add a wedge and you should be there.

    Also is your wear ring ok?
    Oh and get a boost gauge, you very well could be leaking boost.



    /
    Last edited by Water4fire; 08-04-2006 at 07:16 AM.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 rxp stage 3 or 08 rxp x what to buy
    By trent_girardrxp in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 10-04-2011, 05:53 PM
  2. For Sale 05 RXP, Stage II, with Trailer
    By GregHoss in forum Sea Doo 4Tec Skis
    Replies: 6
    Last Post: 06-01-2009, 10:44 PM
  3. Think these RXP's are3 going to sell for $50000?
    By red rider in forum Open Discussion
    Replies: 0
    Last Post: 02-28-2008, 01:12 AM
  4. 05 Rxp Stage 3 Disaster
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-03-2007, 11:57 PM
  5. 05 RXP Stage 2 Possible SC Clutch Problem?
    By Colby in forum 4-Tec Performance
    Replies: 5
    Last Post: 01-28-2007, 12:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •