Results 1 to 4 of 4
  1. #1

    Join Date
    Jun 2009
    Location
    Holyoke, MA
    Posts
    31

    2001 GTX DI speed and rpm loss

    I have a 2001 GTX DI, it has been running great up until today. I went out and started off fine, after about 20 minutes or so I noticed it wouldn't go past 48mph. I then checked the rpm's and they were barley hitting 6000. Everything seems to run fine until you reach that point, which is just past half throttle. So the throttle, from just past the half way point does nothing. I can move it from that point to full throttle with no difference in rpm's.

    I haven't checked anything out yet as it started raining when I got home. Any ideas where I should start looking?

    Thanks in advance,
    -Jamie


  2. #2

    Join Date
    Jun 2009
    Location
    Holyoke, MA
    Posts
    31
    I forgot to mention that my idle rpm's are now at 1450 and they were at 1750. Please help!!!

  3. #3

    Join Date
    Jun 2009
    Location
    Holyoke, MA
    Posts
    31
    Anyone????

  4. #4
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    It could be the fuel pump. You will need to test both the fuel pressure and fuel volume per the Service Manual to know for sure before you spend $500 on a new pump... Ron

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 GTX DI starts and then immediately stops
    By dandlwelder in forum 2-Stroke Performance
    Replies: 24
    Last Post: 04-16-2016, 08:08 PM
  2. 2003 GTX NA Power and Rpm loss............
    By 4skis in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-01-2015, 08:22 PM
  3. 2001 GTX DI Bogging out below 2000rpm's and over 4000 rpm's
    By joeyaguiar in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-06-2010, 04:50 PM
  4. 2005 GTX IC 215 Lower speed and rpm's
    By juanco123 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-07-2008, 01:14 PM
  5. Loss of speed and RPMs
    By NJ-Ski in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-21-2006, 10:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •