Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Did I buy a lemon yellow 03 Sportster?

    Hey guys great site! need some help just bought an 03 Sportster 4-tech not used since 04 supposed to only been used twice. Drained the fuel put a new battery started up great on the hose Put it in the lake today just seams to get cavitation before it gets on a plane none of the gauges work and the oil light comes on a a loud beep follows till I shut it down and restart Checked the impeller seams to feel dented up. all the fuses look fine oil is full. I am fairly mechanically inclined is the impeller a big job expensive? I know this is a big firts post but thanks in advance for any help.


  2. #2
    Former 2 stroke hater!
    Join Date
    Jun 2009
    Location
    louisiana
    Posts
    109
    Sounds like you need a new impeller (if it's dented up) and wear ring. Neither are a big job and being a wrencher you should be able to do it in a couple of hours.

  3. #3
    Thanks samsfiveo I''m sure my local shop is weeks out just in time for fall. Any idea where I can get some instructions?

  4. #4
    flyguytki's Avatar
    Join Date
    May 2008
    Location
    Daytona Beach Fl
    Posts
    443
    Right here big guy!! Going to be a little different than most of the How Too's posted sinces its a boat not a ski but everything should be fairly similar, I just pulled the pump on an 08 challenger yesterday and it was just as easy as the skis were.

    http://greenhulk.net/forums/showthread.php?t=536


    Only 2 "Special" tools you will need are a impeller tool (available in the online store) and a 12mm Allen Wrench, not to common but Sears has them for $6 or so.

    If you have any questions just ask, people are always more than welcome to help out. Finally If you are mechanically inclined do not waste your money at the dealer, These machines are way to easy to work on if you just put a few hours in and look them over to see how everything works.

    -david

  5. #5
    Thanks, David That pump was not bad at all to take out with the instructions posted. You Guys are AWESOME! The impeller is in real bad shape the pump housing is plastic and it took out some the leading edge of the veins on the inside of the housing is this a must to replace will it affect the performance of the boat?

  6. #6
    nightrider05's Avatar
    Join Date
    Sep 2007
    Location
    Show Me State -STL
    Posts
    386
    Quote Originally Posted by badluck View Post
    Thanks, David That pump was not bad at all to take out with the instructions posted. You Guys are AWESOME! The impeller is in real bad shape the pump housing is plastic and it took out some the leading edge of the veins on the inside of the housing is this a must to replace will it affect the performance of the boat?

    I wouldn't be as worried about the veins as I would about the wear ring and impeller. If anything you could smooth the veins out a bit with a dremel. The main thing is that you have the right amount of clearance between the impeller and wear ring.

  7. #7
    zerowake's Avatar
    Join Date
    Mar 2009
    Location
    Gahanna
    Posts
    336
    Quote Originally Posted by badluck View Post
    Thanks, David That pump was not bad at all to take out with the instructions posted. You Guys are AWESOME! The impeller is in real bad shape the pump housing is plastic and it took out some the leading edge of the veins on the inside of the housing is this a must to replace will it affect the performance of the boat?
    can you post a pic of the pump and damage to the veins?

  8. #8

    Smile What a fun boat thanks for the help.

    Just replaced the housing an a new Solas impeller this thing is a blast! Still no tach, speedo or fuel guage any ideas fuse is fine and have power to the back of the guages.

  9. #9
    Fuses are usually labeled incorrectly so do check them all.

    As for the beeping you mentioned and the oil light coming on you will need to replace the oil pressure sender. Fairly cheap and real easy to replace. Same thing happened on my old speedster 150.

  10. #10

    3 bad Guages?

    Sorry guys gave up and took it to the dealer to look at the gauge problems After $300 and and 7 days they told me all Tach, Spedo and fuel gauges are bad from sitting they verified only 4 hours $700 to replace all them I think they also lost my oil filler cap and no one has one in stock does any one know of a auto one that will work?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Warning buzzer stays on all the time? 03 Sportster 4-tech
    By badluck in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 08-18-2009, 11:38 AM
  2. Optima Battery, Did I buy the right one???
    By Lukester in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 12-30-2008, 06:58 PM
  3. What did You Buy On Black Friday!!!
    By ADAMBOMB in forum Open Discussion
    Replies: 15
    Last Post: 11-26-2007, 12:53 PM
  4. Help with 03 Sportster 4 TEC Mods
    By btheboat in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 09-25-2006, 04:41 PM
  5. 70 mph GSXL - why did I buy an RXP???
    By JAG in forum Sea Doo Open Discussion
    Replies: 21
    Last Post: 09-13-2006, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •