Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Jul 2008
    Location
    Stratford,Ct
    Posts
    960

    Has anyone installed the 137MM charger with stock injectors

    On an X ski and left it alone,I ran mine for hours last year and had not a problem,actually put over 120 miles of beatings in a single day with no problems. but i took the advice from all and put 50#ers in but never installed a adj reg setup.IT really runs like crap low speeds with the injectors dropped in.
    I am dropping the 42s back in and gonna retest it.

    Just wondering if anyone else has run their skis this way with no problems

    so bottom line does 137mm charger and 42#ers = safe?


  2. #2
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    I would think that you are lean at WOT unless its real hot where you are. It will run lumpy at idle coz of the 50sbut its gona make the engine safe at the top. R88

  3. #3

    Join Date
    Jul 2008
    Location
    Stratford,Ct
    Posts
    960
    It may be safe at WOT with 50#ers,but also running rich enough were its
    losing power.

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    Time to put the o2 gauge on. If you pull the exhaust manifold I can tap it for ya..(While you wait)

  5. #5

    Join Date
    Jul 2008
    Location
    Stratford,Ct
    Posts
    960
    maybe ill do it tonight,I have the tools,not the gauge

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    You could borrow my gauge and your old 42,s for a test..

  7. #7

    Join Date
    Jul 2008
    Location
    Stratford,Ct
    Posts
    960
    are the 42s in you ski?
    Id like to do this i can test maybe wed night.
    I can pull the manifold tomnight and do the atpping,gotta find me a plug for the 02 fitting also

  8. #8
    ctriverguy's Avatar
    Join Date
    Aug 2007
    Location
    Ipswich, Massachusetts, United States
    Posts
    1,509
    +1
    8
    got a spare that came with my kit, your welcome to it.

  9. #9
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    Yes the 42's are in the ski. Two bolts and there out. Auto parts store for the plug Oil drain plug.

  10. #10
    Riding Dirty GP1300R's Avatar
    Join Date
    Dec 2007
    Location
    Connecticut
    Posts
    496
    Otto, I should have o2 sensor plugs at the shop. Give me a call if you need me to bring one home tomorrow.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Has anyone installed a X ski EX IC with success in a older ski?
    By skigolfnut in forum 4-Tec Performance
    Replies: 12
    Last Post: 11-16-2011, 09:04 AM
  2. Has anyone used a 14/19R with a different SC Wheel?
    By NeverEndn in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-13-2007, 05:46 PM
  3. Rude Charger with stock ecu and intercooler.
    By aussie rxp in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-19-2007, 08:49 AM
  4. Has anyone tried the WORX Intake grate
    By jpa1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 04-01-2007, 11:39 AM
  5. Has anyone read the E bay add?
    By 1 FAST VE in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 10-02-2005, 04:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •