Results 1 to 7 of 7

Thread: RXT Oil warning

  1. #1

    Join Date
    Jan 2009
    Location
    UK-South Coast
    Posts
    17

    RXT Oil warning

    Hi

    My friend has an 05 RXT, we are having serious issues with the oil warning....
    it has had 2 new front sensors & 2 new rear sensors, it has also had an oil pressure relief valve fitted by the dealer!!

    For the first 2-3 mins from cold it shows oil warning on the display & goes into limp mode, let it warm up & then it will run great all day, we just did an oil pressure test from cold and it showed 135psi oil pressure, could this real high cold oil pressure be bringing the light on & what could be causing this!!!

    Any ideas??


  2. #2
    Nedo69's Avatar
    Join Date
    Feb 2009
    Location
    Wollongong, Australia
    Posts
    67
    Hey there a re a number of people who have had this issue recently. Myself being one of them. Check the attached thread might shed some light
    http://http://www.greenhulk.net/foru...ad.php?t=96332

  3. #3

    Join Date
    Jan 2009
    Location
    UK-South Coast
    Posts
    17
    Thanks for the link, i think it is sorted, looks like another faulty sensor!

  4. #4
    Nedo69's Avatar
    Join Date
    Feb 2009
    Location
    Wollongong, Australia
    Posts
    67
    Which sensor did you find it to be? Ive started by changing the one out at the rear of the motor underneath the inlet manifold, just havent had the chance to get it in the water to test

  5. #5

    Join Date
    Jan 2009
    Location
    UK-South Coast
    Posts
    17
    It was the rear sensor causing the fault, it seems that the front sensor brings on the engine warning on the display & the rear sensor will bring on the oil warning on the display, we hooked up the rear sensor to a multimeter & then applied 60-80psi air pressure to the sensor it didn't do anything so we heated it with a hair dryer to simulate hot engine, then with 40psi air pressure it started working !!

    Changed sensor now it works fine no oil warning

  6. #6
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,577
    +1
    4,793
    I love a story with a happy ending....

  7. #7
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    +1
    1
    Thats cool that you got it straight. Oil pressure is the biggest pain in the ass with these 4 tecs. I have an 06 that only throws an oil pressure warning when coming off the throttle slowly. WOT everything is fine. Come off the throttle quick and everything is fine. Let off slowly and you get a warning. i took the sensor from that ski and swapped it into my ski and gave him mine. Same story. oil pressure on the gauge looks good. Put in a new regulator and installed it correctly. Same story.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT oil warning problems
    By silverback2002 in forum 4-Tec Performance
    Replies: 11
    Last Post: 09-13-2015, 09:32 AM
  2. NEED HELP! OIL WARNING 2005 rxt
    By cfratt in forum 4-Tec Performance
    Replies: 15
    Last Post: 11-11-2014, 06:15 PM
  3. Rxt oil warning and rattle
    By PAPADOUX in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-10-2013, 08:04 AM
  4. Seadoo Shop doesnt know how to fix my RXT...Oil Warning alarm
    By kaorder1999 in forum 4-Tec Performance
    Replies: 26
    Last Post: 06-29-2010, 07:45 PM
  5. 2005 RXT Oil Warning
    By bic1 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 09-08-2005, 07:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •