Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Apr 2009
    Location
    Between Chicago, IL and Milwaukee, Wi
    Posts
    6

    Computer issues with '09 Sea-Doo GTX Limited IS 255

    I'm writing this thread to see if there are any others having computer issues with their 2009 GTX Limited IS 255's. Mine has now been in the shop THREE weeks.

    I bought mine June 2, 2009 and due to our Chicago weather didn't take it on Lake Michigan until July 1, 2009. I didn't have one hour on the machine when the maintenance light came on. While I was driving back to the marina I did enjoy the new machine and found it light years ahead of my other watercraft. The suspension is wonderful truly helped ease the waves of Lake Michigan. Because it isn't broken in yet I can't speak for the speed, other than it's very fast.

    My other issue with my now 4th Sea-Doo is the quality of the plastic on the Hull. I pointed out to the sales manager there was a scratch on the right side rail as well as the handlebar cover has a great deal of white pitting.
    I have expected more from BRP over the years and have been sadly disappointed recently.


    My Machine has been at Uke's Dirtstore (Part of Uke's Harley-Davidson) in Kenosha Wisconsin for THREE weeks. I've been told by the lead service tech that I've trusted for years that there are computer issues. They have replaced the IS module as well as two other parts and it won't start. I've been told since July 3, 2009 that they've been on the phone with BRP in Canada and they can't seem to find the issue.

    Due to these economic times Uke's Dirtstore (a self standing BRP store) has now been absorbed in the Harley store and the quality of service has fallen to an unacceptable level. I've been a loyal Bombardier customer for over 20 years and watching the quality of service decline. Now I'm looking to forums to see if anyone else has had any issues.

    Please forgive my rant and feel free to add any issues you've had with your 2009 IS models.


  2. #2
    Quote Originally Posted by Lake_Michigan_Guy View Post
    I'm writing this thread to see if there are any others having computer issues with their 2009 GTX Limited IS 255's. Mine has now been in the shop THREE weeks.

    I bought mine June 2, 2009 and due to our Chicago weather didn't take it on Lake Michigan until July 1, 2009. I didn't have one hour on the machine when the maintenance light came on. While I was driving back to the marina I did enjoy the new machine and found it light years ahead of my other watercraft. The suspension is wonderful truly helped ease the waves of Lake Michigan. Because it isn't broken in yet I can't speak for the speed, other than it's very fast.

    My other issue with my now 4th Sea-Doo is the quality of the plastic on the Hull. I pointed out to the sales manager there was a scratch on the right side rail as well as the handlebar cover has a great deal of white pitting.
    I have expected more from BRP over the years and have been sadly disappointed recently.


    My Machine has been at Uke's Dirtstore (Part of Uke's Harley-Davidson) in Kenosha Wisconsin for THREE weeks. I've been told by the lead service tech that I've trusted for years that there are computer issues. They have replaced the IS module as well as two other parts and it won't start. I've been told since July 3, 2009 that they've been on the phone with BRP in Canada and they can't seem to find the issue.

    Due to these economic times Uke's Dirtstore (a self standing BRP store) has now been absorbed in the Harley store and the quality of service has fallen to an unacceptable level. I've been a loyal Bombardier customer for over 20 years and watching the quality of service decline. Now I'm looking to forums to see if anyone else has had any issues.

    Please forgive my rant and feel free to add any issues you've had with your 2009 IS models.
    I have one patch software upgrade that needs to be done! I only have 1 hour on it to date! Its the RXTX IS, so far no issues and I like the shock set-up! Runs great!

  3. #3

    Join Date
    Jan 2009
    Location
    Chicago & New Buffalo, MI
    Posts
    53
    Quote Originally Posted by Lake_Michigan_Guy View Post
    I'm writing this thread to see if there are any others having computer issues with their 2009 GTX Limited IS 255's. Mine has now been in the shop THREE weeks.

    I bought mine June 2, 2009 and due to our Chicago weather didn't take it on Lake Michigan until July 1, 2009. I didn't have one hour on the machine when the maintenance light came on. While I was driving back to the marina I did enjoy the new machine and found it light years ahead of my other watercraft. The suspension is wonderful truly helped ease the waves of Lake Michigan. Because it isn't broken in yet I can't speak for the speed, other than it's very fast.

    My other issue with my now 4th Sea-Doo is the quality of the plastic on the Hull. I pointed out to the sales manager there was a scratch on the right side rail as well as the handlebar cover has a great deal of white pitting.
    I have expected more from BRP over the years and have been sadly disappointed recently.


    My Machine has been at Uke's Dirtstore (Part of Uke's Harley-Davidson) in Kenosha Wisconsin for THREE weeks. I've been told by the lead service tech that I've trusted for years that there are computer issues. They have replaced the IS module as well as two other parts and it won't start. I've been told since July 3, 2009 that they've been on the phone with BRP in Canada and they can't seem to find the issue.

    Due to these economic times Uke's Dirtstore (a self standing BRP store) has now been absorbed in the Harley store and the quality of service has fallen to an unacceptable level. I've been a loyal Bombardier customer for over 20 years and watching the quality of service decline. Now I'm looking to forums to see if anyone else has had any issues.

    Please forgive my rant and feel free to add any issues you've had with your 2009 IS models.

    I Have a gtx is limited. It too broke down the 1st time out. Computer problems.

    Software needs to be updated before even the 1st time out or it will break down

  4. #4
    jkflow's Avatar
    Join Date
    Jun 2007
    Location
    Tampa, FL
    Posts
    77
    +1
    4
    No issues except the maintenance light coming on. It came on within 1h and was reset at the 10h mark. Dealer didn't reset it correctly and came on again after 1h (11h). Chalked that one up to learning curve at the dealership. No issues since (22h now).
    Sounds more like you have an incompetent dealer than a ski issue. I'd take it somewhere else if you have an option. Times are tough and restructuring a business never improves the service. At least not during the phase. I bet you that they are not letting their people get the training needed because it costs money.

  5. #5
    Quote Originally Posted by jkflow View Post
    No issues except the maintenance light coming on. It came on within 1h and was reset at the 10h mark. Dealer didn't reset it correctly and came on again after 1h (11h). Chalked that one up to learning curve at the dealership. No issues since (22h now).
    Sounds more like you have an incompetent dealer than a ski issue. I'd take it somewhere else if you have an option. Times are tough and restructuring a business never improves the service. At least not during the phase. I bet you that they are not letting their people get the training needed because it costs money.

    Yes, its a learning for a lot of dealers! When I bought mine they had to go through a lot of upgrades before it went out the door! They were up front that there is some technical stuff. There are dealers that haven't sent thier mechanics to seminars on this boat yet! They will evevntually have too! Keep on the software is the key to these setups!

  6. #6

    Join Date
    Apr 2009
    Location
    Between Chicago, IL and Milwaukee, Wi
    Posts
    6

    Re:

    Thank you all for your replies, I must say it is very frustrating that my new Machine has been in almost a month. I talked to them today and advised them I'm contacting BRP if I don't have it back this week. To the point made about lack of training, I know their lead tech was the only person sent to it. So, he's the only employee that has the knowledge of the new models.

    As I've said, I've never had a problem with this dealer. That is quickly changing and if things don't improve in their quality of service, I will be looking for another dealer. Anyway, I'll update my post when I have more to share. I do appreciate everyones input and offerings of help.
    Jim

  7. #7
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Sorry to hear about your ski not running properly. It being in the shop for that long is not right. Hopefully they can get it worked out for you soon!

  8. #8

    Join Date
    Apr 2009
    Location
    Between Chicago, IL and Milwaukee, Wi
    Posts
    6

    Just thought I'd give you guys an update.

    Thank you again for all of your posts, I do appreciate it. This afternoon I went to the dealership in person and spoke with darn near everyone there. I was there for 2 1/2 hours trying to resolve this issue. As I said in my first post, I do trust their lead tech, however he's the only one trained in the new computer equipment for the 2009 machines. He showed me his detailed notes of what he had done and the two hours a day he has spent on the phone with BRP.

    He handed me the customer service number for BRP and said if they heard the very valid complaint from their loyal customer, things may go smoother.
    It took me ONE hour to get past the voice message (your call is very important to us, please stay on the line). I must say, that got very cumbersome, very quickly. However, it may have paid off.

    I spoke with customer service, then their lead tech guy in Canada. They have isolated the issue to a computer driver issue and BRP has formed a "Task force" just for this issue, there are a great deal that are having the same problem. When I get more info, I will pass it along so it may help others in the future.

    I was told it should be fix tomorrow. Time will tell and I hope they're right. Saturday will be one month and I told them I've lost in essence, 50% of the best part of the season. They agreed, however have offered little except we'll continue to do our best.

    If all goes well, I'll be on Lake Michigan on Monday when I get back in town.
    Thank you again for your assistance.

  9. #9
    2Blue's BFF! dsolie's Avatar
    Join Date
    Apr 2007
    Location
    Olympia, WA
    Posts
    832
    +1
    1
    At least you know your dealer is batting for YOU, and working on your behalf. That, in my mind is at least a little re-assuring.

    I would keep that dealer if you trust the tech. To me it seems like they are doing everything in their powers to get you back on the water...

  10. #10
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11
    Glad to hear Seadoo sees you have a valid issue and are working towards resolving it! Hope you get on the water soon and get to enjoy your iS!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2009 sea doo gtx limited iS 255
    By chibikiddo1989 in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-21-2016, 01:54 PM
  2. 2009 Sea Doo GTX Limited iS 255 Analog Speedo Not Working
    By rockytop in forum 4-Tec Performance
    Replies: 0
    Last Post: 10-21-2015, 11:45 AM
  3. FS 2005 Sea Doo GTX Limited 215hp SC with 57 Original Hours
    By seatsR4toilets in forum Sea Doo 4Tec Skis
    Replies: 15
    Last Post: 06-28-2011, 12:23 PM
  4. Replies: 10
    Last Post: 12-09-2008, 04:10 PM
  5. 2007 Sea-Doo GTX LIMITED
    By Paulz01 in forum Sea Doo Classifieds
    Replies: 7
    Last Post: 06-13-2008, 10:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •