Results 1 to 5 of 5
  1. #1

    Polaris SL 750 bogging down

    I've got a Polaris SL 750 that seems to run great other than this. I was out on it this past weekend and the fuel cap for my Kawasaki broke off the chain and sank at the marina gas dock (totally surprised by that, you would think they would float). Anyway, I had to load myself and 2 girls on the Polaris to get back to our dock and on the way back it sounded like the engine was boggoing down or getting flooded or something. I coulod give it full throttle and would not really go anywhere or get up on plane. It did this for about 20 minutes after I got them off of it and ran it myself and it seemed to work itself out I think. Any idea what may have caused this?


  2. #2
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    3 people on a 750 is a load,If you couldn't really get it up on plane and was lugging it back,you may have fouled a plug or wetted one good. So it runs fine now? Run a compression check just for grins,and take a look at the plugs.

  3. #3
    How would I know if a plug was fouled by pulling them out and looking at them?

  4. #4
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Yes, They should be dry and a light brown. One that looks black and wet maybe fouled. They run about 3.00 each,pick up a set and replace them,you can always save the old ones for back-ups. Sometimes they may look good and still be bad,but generally not.

  5. #5
    I'll check it out. Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 Polaris slt 750 bogs down
    By Bgarcia in forum Polaris PWC Performance
    Replies: 4
    Last Post: 07-28-2015, 02:24 PM
  2. polaris slt 750 bogs down then goes
    By derocherj in forum Polaris Open Discussion
    Replies: 14
    Last Post: 07-04-2015, 07:59 AM
  3. 94 sl 750 bogs down on deceleration
    By Fasterner in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-30-2011, 05:48 PM
  4. polaris sl 750 bogging and hard acceleration from idle?
    By mogyver69 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-28-2011, 09:41 PM
  5. new to forum....94 SL 750 bogging down?
    By ttown in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-15-2007, 01:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •