Results 1 to 8 of 8
  1. #1
    Chicago RXP'er Jaronk56's Avatar
    Join Date
    Aug 2008
    Location
    Chicago
    Posts
    465

    3 questions.. pisser and adhesive...

    1. OK first question... I dont want to run the exhaust pisser at outlet... I know i can bilge it... any other options???? plug? ect????

    2. WHAT do you guys use to adhere your bilge PUMP to hull!... I've failed so far..

    3. Mat adhesive.... what to get at home depot????


    Thanks as always!

    Jaron


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Plug it or run a pisser.
    I used a 2 part epoxy to hold my bilge. I also know some that use 5200 sealant.

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    I actually used 2 small self tapping screws about 1/2"-3/4" long and screwed it down. No problems yet. Just make sure they are not too long obviously..lol The hull is pretty thick back there.

  4. #4
    Banned User
    Join Date
    Aug 2007
    Location
    Reading PA
    Posts
    1,670
    not sure what u mean by pissers u mean u want to run ur water lines out of the hull instead of the waterbox???

  5. #5
    Chicago RXP'er Jaronk56's Avatar
    Join Date
    Aug 2008
    Location
    Chicago
    Posts
    465
    Quote Originally Posted by speedskixp View Post
    Plug it or run a pisser.
    I used a 2 part epoxy to hold my bilge. I also know some that use 5200 sealant.
    How would i go about pluging it, whats the best way??

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by Jaronk56 View Post
    1. OK first question... I dont want to run the exhaust pisser at outlet... I know i can bilge it... any other options???? plug? ect????

    Bilging it is probley the best way..Then you dont need to worry about plugging hoses and taking excessive water in the water box..
    On the exhaust tip you can remove the fitting and put a plug in there..

    2. WHAT do you guys use to adhere your bilge PUMP to hull!... I've failed so far..

    5200 sealent..when using this or any type of epoxy make sure the surface is clean..Also it doesnt hurt to scuff the surface with sand paper too..This will let the epoxy/sealant adhear to the surface better..

    3. Mat adhesive.... what to get at home depot????


    Thanks as always!

    Jaron

  7. #7
    Chicago RXP'er Jaronk56's Avatar
    Join Date
    Aug 2008
    Location
    Chicago
    Posts
    465
    Thanks very much snowman for the great info! I guess i will bilge! i didnt think about the waterbox relief and im always tinkering in the garage with the hose!

    im going to pick up some 5200 tonight


    Thanks again!

  8. #8
    camar0's Avatar
    Join Date
    Apr 2007
    Location
    Sunshine
    Posts
    787
    I have tried the bildge on both sides in the back... so far i seem to like it on the side with the waterbox in the back.... because if it ever comes loose i can fix it compared to under the XS IC is just too time consuming to remove everything...

    i used brake cleaner and TB cleaner in the back where i was going to stick it, then got a flat head screw driver and scraped the finish up alittle...
    then used clear adhesive sealant on the bottom and side of the bildge... hasnt moved since...

    i put the bilge right next to the hull (pump side) so i could glue 2 sides..... i never had luck with just mounting the bottom with the 5200 sealant...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts WTB Yamaha FX SHO intercooler outlet (Pisser) and Skat nose cone.
    By dso8950 in forum Yamaha Classifieds
    Replies: 10
    Last Post: 09-01-2014, 07:52 AM
  2. Impeller swap - few quick questions (grease and rubber piece)
    By loudsubz in forum Honda How To & FAQs
    Replies: 0
    Last Post: 05-10-2012, 08:52 PM
  3. GP1200 int shaft and jetpump questions(pics and video)
    By Cutlass in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 04-04-2011, 06:51 PM
  4. some basic questions 1050 and 780.....
    By kanda in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-01-2009, 09:53 PM
  5. Polaris sl750 questions (waterleak and trim)
    By smittyj77 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-24-2007, 03:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •