Results 1 to 6 of 6
  1. #1

    Join Date
    May 2006
    Location
    Cincinnati
    Posts
    697
    +1
    3

    carbon seal, drive shaft seal??

    ok I"m having cativation problems, and some one mentioned the carbon seal, I"m not familure with this part, my old seadoos just had the rubber hose and the bearings on the drive shaft. anyways. I was looking at my drive shaft while putting in my riva filter, and the rubber rippled cupler buts up against the metal ring on the drive shaft. I can wiggle this around its not really sealed to the shaft, it jsut kinda rests up against that flarred metal there. Is that correct?? or is this a problem?? I didn't notice the ski taking on any water when I had it out.. I flipped the new wear ring over to see if that was it.. the 14/19r spins freely in the ring but scrapes a bit,, I cant believe it would eat a wear ring in about 3 hrs of riding anyone??


  2. #2

    Join Date
    Apr 2005
    Location
    Elysian Fields,Tx
    Posts
    358
    There should be two halves of the carbon ring seal. There is the metal piece the two halves of the seal and a spring behind them.These skis do eat up wear rings pretty bad but 3 hours is really bad. It is caused from shaft deflection,mostly caused by excess hard acceleration.You could also have an alignment problem. The wear ring problem is why we all go to the stainless wear ring. If you go to a SS wear ring you need the triple bearing setup.

  3. #3

    Join Date
    May 2006
    Location
    Cincinnati
    Posts
    697
    +1
    3
    well I was accellerating hard, it was first day I got my stage one on.. I Was trying to get gps readings... so maybe I did toast the wear ring.. the ski only has 13 hrs on it... but I flipped the ring tonight I'll see how it is tomarrow... I dont wanna do the tripple bearing mod I head its expensive and alot of people have had issues.. what about the RR motor mount??

    Also could it maybe be the solas prop?? maybe it was machined out of spec alittle to chew a wear ring???

  4. #4
    buddydoo's Avatar
    Join Date
    Oct 2005
    Location
    houma
    Posts
    958
    +1
    9
    I just changed my carbon seal and the seal gasket because of cativation and can't wait to gave it a run sunday to see if that will fix the problem with that cativation.If that don't work it's got to be the pump going out,time for the triple bearing mod.

  5. #5
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,898
    +1
    506
    Do the front mount thats one of the weak links!

  6. #6

    Join Date
    May 2006
    Location
    Cincinnati
    Posts
    697
    +1
    3
    this is an 06 with 13 hrs on it I'll be pissed if its the carbon seal

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB 04 RXP Support Ring drive shaft carbon seal
    By Derek45 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 04-08-2014, 09:31 PM
  2. drive shaft removal ,carbon seal, etc questions
    By wazoo3 in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-24-2011, 08:03 PM
  3. Drive shaft carbon seal questions
    By RumRunnerRon in forum 2-Stroke Performance
    Replies: 6
    Last Post: 04-21-2010, 03:45 PM
  4. Drive Shaft Seal Help
    By stabs in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 06-16-2008, 12:57 AM
  5. Question on drive shaft seal
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 09-27-2007, 12:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •