Results 1 to 2 of 2
  1. #1

    1999 XPL MPEM help

    I went to Harry Ks MotorSports to have a new MPEM installed. Since I had it installed I have had a couple problems First is that the Beeper is activated at 7/8 tank or less....
    Second problem is that the fuse that is supposed to be used for the Bildge pump is labled as spare...
    I removed the MPEM and see NO markings on it beside
    PBT-GF40
    AND
    DECSO
    071000-1330
    Made in Japan

    Is it possible that I got the wrong MPEM... IT does work besides that... Except the speedo


  2. #2

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    the 1330 mpem is used in the 98 GTXL/GSXL-- single coil setups. Sounds like someone did some modifications to your machine or you have a 98 XPL.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 10-16-2010, 09:28 AM
  2. jet carbs on 1999 XPL
    By BGslugger in forum 2-Stroke Performance
    Replies: 11
    Last Post: 08-15-2007, 05:53 PM
  3. 1999 XPL low conpresion...need help
    By BGslugger in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-06-2007, 07:08 PM
  4. 1999 XPL low conpresion...need help
    By BGslugger in forum 2-Stroke Performance
    Replies: 0
    Last Post: 08-06-2007, 01:37 PM
  5. help bulding a Limited Boat for racing...1999 XPL
    By BGslugger in forum 2-Stroke Performance
    Replies: 0
    Last Post: 08-03-2007, 10:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •