Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 33

Thread: I did it...

  1. #1
    the franchise dogger's Avatar
    Join Date
    Mar 2006
    Location
    The Panhandle
    Posts
    572

    I did it...

    The wife and I picked up a shiny new FZS tonight, black of course. Looks like the first thing I need is the new grate and PPK kit to resolve the buck.

    I found Jerry's thread to be awesome for the answers I already needed.

    Cant wait to turn this into a wicked project.

    I'll miss my lil GPR.




  2. #2
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    I don't believe the PPK mod is needed. Just the grate, and check to make sure your transom plate is squared up.

  3. #3
    the franchise dogger's Avatar
    Join Date
    Mar 2006
    Location
    The Panhandle
    Posts
    572
    never caught that about the transom. I will search for the transom issue. thanks.

    this was what I was talking about for PPK, the riva pump seal kit. If it isnt needed, what is everyone doing about filling the voids?

    http://www.4-tecperformance.com/inde...oducts_id=1156

  4. #4
    flyboy's Avatar
    Join Date
    Nov 2005
    Location
    Destin, FL
    Posts
    1,585

  5. #5
    javajoe's Avatar
    Join Date
    Jun 2009
    Location
    Maryland
    Posts
    181
    Congrats on the new ski.
    And nice looking GPR by the way!

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    congrats on the new ski

    You need the pump seal kit with the grate.

  7. #7
    KamikazeGPR's Avatar
    Join Date
    Mar 2007
    Location
    Philadelphia
    Posts
    1,361
    +1
    99
    The R&D plug kit has a nice tight fit. Much nicer than their gpr kit.

    When i put the pieces in the grate. They stuck out like 3/16". I thought damn, i have to grind this crap. Then i put the pieces in the transom and saw they were recessed about the same 3/16".

    When i put the grate up the plugs sticking out of the grate went into the recess of the transom plate for a nice tight seal. I'm not using 3m fast cure. The fit of the plugs is so nice there just doesn't seem to be a need to seal it.

    I did have to take .70 off the mounting bosses to make the grate sit flush with hull and transom plate though.

  8. #8
    FRANKY G's Avatar
    Join Date
    Nov 2008
    Location
    U.S. Riverside Ca.
    Posts
    279
    Congrats on the new ski. Have fun and let the mods begin..
    I like that GPR bro! Sweet...

  9. #9
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,132
    +1
    205
    Quote Originally Posted by dogger View Post

    you got a cummins?

  10. #10
    Addicted Member 5001craig's Avatar
    Join Date
    Jul 2007
    Location
    Northeast Indiana
    Posts
    2,924
    +1
    11
    Quote Originally Posted by mazy View Post
    you got a cummins?
    Doesn't everyone?

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I did it......!!!
    By xRXPMike in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 06-16-2007, 11:19 PM
  2. Finally did it.
    By catchme in forum 4-Tec Performance
    Replies: 0
    Last Post: 01-23-2007, 12:17 PM
  3. Lost RPM, where did it go???
    By DandSPro in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-09-2006, 06:08 PM
  4. How long did it take Skat to...
    By Totallyblown in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 05-02-2006, 09:55 AM
  5. welp..i did it!
    By mxl16 in forum 4-Tec Performance
    Replies: 15
    Last Post: 01-20-2006, 07:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •