Results 1 to 2 of 2
  1. #1
    cigarlust's Avatar
    Join Date
    Apr 2008
    Location
    Funky town (Fort Worth TX)
    Posts
    1,171
    +1
    2

    05 R-12x Pump re-install question

    Ok, I am an official tard. I was putting my pump back together last night and used the 4 (longer) pump nozzel bolts where the pump bolts to the hull. Now when I use the correct shorter ones they thread in correctly but won't snug down... I gave the pump a good tug and it's attached, but the fact I can't get them to snug down really has me worried. WTF did I do and how can I fix it?


  2. #2
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    The pump is lined up with dowel pins, It would appear to be ok but if the bolts aren't torque correctly you will have a intake leak.

    Remove the pump and run a bottom style tap in the threads carefully and reinstall the pump.

    Shawn

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine re-install question/shim plates
    By gkecorp in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-19-2009, 09:28 AM
  2. pump shoe install question
    By emcewin in forum Yamaha How To & FAQs
    Replies: 10
    Last Post: 02-18-2009, 11:11 PM
  3. Pump Housing Installation Question
    By kl7741 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 01-16-2009, 01:55 PM
  4. Pump Wedge Install Question
    By BLACKSTI in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 08-28-2007, 05:30 PM
  5. '05 RXT/GTX RR IC install question... O-ring?
    By 05Limited in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-03-2005, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •