Results 1 to 8 of 8
  1. #1
    Chaserxp215's Avatar
    Join Date
    May 2008
    Location
    Grosse Pointe, MI
    Posts
    943

    RXP Acting Up???

    Hey guys,
    Took off my rxp out for a ride today. I rode it pretty hard just setting up a few bouys and running a mini course. On my way home I was still running pretty hard and I heard it beep. When I looked it showed 2 bars of gas. I just thought it took a wave and bounced the float down to 1 bar and the alarm went off. I heard it beep again I had 6 bars...??? Beeped 2 more times, it was going off lk every 30 seconds. Then it beeped 1 more time and then quicked beeped again. I kinda felt a loss of power so I shut it off immediatly looked under the seat no issues, no codes... nothing. So I started it up again and rode for 10 min more and no issues, no beeping etc...??? I am at a loss. Idk if it just like decided to freak out for some reason. Or the fuel float or something is broken. I am showing 5 or 6 bars now and I am going to the gas station to see how much gas its going to take. I am going out of town late tonight so after tonight I may not reply to this thread. Anybody have any idea. Thanks in advance.


  2. #2
    Chaserxp215's Avatar
    Join Date
    May 2008
    Location
    Grosse Pointe, MI
    Posts
    943
    put 8.5 gallons in so I would think that the fuel float is ok???

  3. #3
    Chaserxp215's Avatar
    Join Date
    May 2008
    Location
    Grosse Pointe, MI
    Posts
    943
    bump 1 last time and after that I am guessing that it was just a fluke thing...??? I will take it out this week and see if it does it again.

  4. #4
    Chaserxp215's Avatar
    Join Date
    May 2008
    Location
    Grosse Pointe, MI
    Posts
    943
    Ok, took it out today... its really weird now. Starting riding and it beeped later on it beeped again then the motor died... pulled the key, put the key back on and nothing. After playing around opened the hood it turned on... im sooo stumped, then it shut off again when riding. It just doesnt make sense. Its obviously something electrical i'm guessing. If someone can tell me the connections to check and stuff. I just dont have the money to take it to the dealer right now so I am kinda stuck on land until somebody helps me out!!! Please!!!

  5. #5
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by Chaserxp215 View Post
    Ok, took it out today... its really weird now. Starting riding and it beeped later on it beeped again then the motor died... pulled the key, put the key back on and nothing. After playing around opened the hood it turned on... im sooo stumped, then it shut off again when riding. It just doesnt make sense. Its obviously something electrical i'm guessing. If someone can tell me the connections to check and stuff. I just dont have the money to take it to the dealer right now so I am kinda stuck on land until somebody helps me out!!! Please!!!
    There is 2 fuses in the harness next to the starter sylinoid on the side of the mpem. They are each in a little black casing. Pull those 2 fuses and inspect them for corrosion and look closely at them for black arching marks in the plastic. Clean any corrosion off the connectors and replace the fuses with new ones.

  6. #6
    Chaserxp215's Avatar
    Join Date
    May 2008
    Location
    Grosse Pointe, MI
    Posts
    943
    thanks for the info. I will check into it this weekend and I will see where to go from there. I forgot I have to get my wisdom teeth pulled today so I will be out of commision for a day or two.

  7. #7
    outboard john's Avatar
    Join Date
    Jun 2006
    Location
    Escondido, Ca.
    Posts
    474
    +1
    2
    Quote Originally Posted by Chaserxp215 View Post
    thanks for the info. I will check into it this weekend and I will see where to go from there. I forgot I have to get my wisdom teeth pulled today so I will be out of commision for a day or two.
    Lucky Best of luck with the surgery

    OBJ

  8. #8
    Chaserxp215's Avatar
    Join Date
    May 2008
    Location
    Grosse Pointe, MI
    Posts
    943
    haha thanks man. I got about 4 hours left before. I have heard that some people are like fine the next day and some people dont do so well. Hopefully Ill be moving by this weekend and can see if I can fix the machine. On the positive side I get to have unlimited frosty's hahahha.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 9 Hr RXP Acting Up anybody got an ideas???
    By excess in forum 4-Tec Performance
    Replies: 9
    Last Post: 01-17-2008, 08:47 PM
  2. crankshaft acting up
    By exodo90 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 06-22-2007, 08:31 AM
  3. RXP breaking up under boost
    By blackvr in forum 4-Tec Performance
    Replies: 22
    Last Post: 05-28-2007, 09:05 AM
  4. '04 RXP Acting funny
    By scgolfer88 in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-22-2007, 12:09 AM
  5. rxp waken up
    By yellow jacket in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-20-2007, 06:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •