Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46

    Fuel pressure changing with BEGI

    Can any1 tell me that has some expirience with the BEGi fmu if they have seen the pressure changing when putting the key on.

    I got my BEGi all setup last night and did my first tests on the hose all ok apart from I needed a restrictor for the boost line. I had my turbosmart set at 30psi for idle, the BEGI set at around 45 and then the pressure was going up to much with boost till i fitted the restrictor.

    So I came home tonight and when i first put my key to the post I checked my pressure and it was in the 60s??? So I adjusted it down with the engine running but with the boost line unattached to 45psi again and did some more testing with the restrictor and all is looking good for the amount of gain I am getting but I left the ski for around 2 hours and went back out to fit my LC1 for some water testing. Checked my pressure on the key again and now its reading 68psi?????

    I could not start the ski again as it was late and i didnrt wana give any1 the piss so will have to wait til tomorrow now. Just wanted to know if any of you had seen this before??

    Thanks R88


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Do you have the check valve installed in the proper direction? My orfice is a #67 drill bit (.8382mm .033")and the needle valve is four turns out. Set the Begi base PSI with engine idling boost line disconnected. No need for a boost line to the 1:1. Under vacuum the Begi should be open and the 1:1 controls idle.

  3. #3
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by beerdart View Post
    Do you have the check valve installed in the proper direction? My orfice is a #67 drill bit (.8382mm .033")and the needle valve is four turns out. Set the Begi base PSI with engine idling boost line disconnected. No need for a boost line to the 1:1. Under vacuum the Begi should be open and the 1:1 controls idle.
    Yep thats how I have it set it was all working just fine on the hose and I tested with my compessor added 10psi "boost" and got my 73-4psi I want so that is looking good. The pressure is reading odd when I put my key on the post but dont start just like when you are setting the RRFPR normaly.

    I put the key on and I should see what the BEGi is set to coz there is no vacume due to engine not running but instead of seeing 45psi where I set it Im seeing 68psi???

    I couldnt try starting it coz of noise so im not sure if it will act as it should as soon as I start the ski.

    I made my restrictor with a .8mm drill bit but It prob drilled a little over which would put me right where you are with yours. R88

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Is the Begi new? maybe a stuck diaphragm. Wait till you can start it and see if she works under vacuum.

  5. #5
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    I have seen what you are taking about however I disconnected the boost line and checked again at idle and it went back to where I set it. I cant explain why but I did see what you are talking about. BTW the restrictor that came with the begi worked great on both of the begis I've set-up.

  6. #6
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by beerdart View Post
    Is the Begi new? maybe a stuck diaphragm. Wait till you can start it and see if she works under vacuum.
    Barely used I got it off a guy that was building a turbo fireblade but he went with stand alone ECU so had no need for the reg.He had only run it a couple times witht he reg fitted. I just want this to work been having fuel pressure issues for toooooo long now. R88

  7. #7
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    I got mine off e-bay and at first I was having smiler problems come to find out my diaphragm was upside down the metal shim should face the seat.

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    pic

  9. #9

  10. #10
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by speedskixp View Post
    I have seen what you are taking about however I disconnected the boost line and checked again at idle and it went back to where I set it. I cant explain why but I did see what you are talking about. BTW the restrictor that came with the begi worked great on both of the begis I've set-up.
    OK good so im not the only 1. I dont really care what it does on the key if it works when its running I just didnt understand why it would doit??? strange. I got he LC1 hooked up for tomorow im just hoping for flat water coz I only be setting my idle in the harbour if not. Small steps. I did not get a restrictor with mine as the guy wernt using 1. I just made 1 at work out of ally and put a .8mm drill up the middle. I may still be getting a little to much rise but I have only tested with a compressor with engine at idle so ill see what it does in the water under load. R88

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel Pressure Changes with temperature
    By prowler1k in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-16-2015, 03:23 PM
  2. Fuel pressure changes
    By Madmike1 in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-02-2014, 10:54 PM
  3. Replies: 4
    Last Post: 08-06-2012, 11:49 AM
  4. fuel pressure creep with rrfpr ??
    By breon in forum 4-Tec Performance
    Replies: 17
    Last Post: 06-19-2010, 04:11 PM
  5. Fuel pressure with X charger?
    By Chris0060 in forum 4-Tec Performance
    Replies: 54
    Last Post: 04-29-2009, 04:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •