Results 1 to 10 of 10

Thread: Gio stx15f?

  1. #1
    Daveski's Avatar
    Join Date
    Apr 2009
    Location
    Franklin,WI
    Posts
    488

    Gio stx15f?

    Has anyone ever heard of this? My 08 with 13 hrs it seems every time I check the oil its a little high? I level the motor and check it the same every time.I know the 250 260 with superchargers pressurize combustion, but how could it happen with a 13 hr 08 STX?


  2. #2
    mirror's Avatar
    Join Date
    Jan 2006
    Location
    Seminole, FL
    Posts
    532
    +1
    3
    Never heard of this and have never had the problem in my 5 years of owning one.

  3. #3
    Daveski's Avatar
    Join Date
    Apr 2009
    Location
    Franklin,WI
    Posts
    488
    Anyone else? What are the possibilities? cracked head? bad rings? blow by? It runs perfect! Actually gpsd it at 64.4 today on Lake Michigan after trueing ride plate.

  4. #4
    Maybe the machine is not level fore/aft and or laterally. Smell the oil on the dipstick, if it stinks like gasoline oil dilution may be taking place. Then I'd look at the spark plugs to verify a rich mixture. They should be a light tan color. If it has standard power and normal fuel economy there should not be a mechanical issue.

    The other thing with blow-by is it happens both on compression and power stroke. Because the power stroke has more pressure the dirty exhaust should stain the oil pretty fast. Water contamination will make the oil milky. Remember the machine is normally aspirated so a fresh mixture charge is not under the same pressure as with a boosted system.

  5. #5
    Dubz1's Avatar
    Join Date
    Oct 2006
    Location
    Southern California
    Posts
    2,509
    I own an 05 and have never had an issue.

  6. #6
    Daveski's Avatar
    Join Date
    Apr 2009
    Location
    Franklin,WI
    Posts
    488
    Well, Just dropped off ski at dealer for the recalled gas tank and my gio issue, They will do a compression leakdown test and whatever else kawi lets them do. I now am assuming the rings are bad or didnt seat properly, I put my 2 cents in for new 2009 pistons and rings, we shall see, looks like my season is pretty much over now, who knows when I will get it back. I will keep you all posted on what they come up with and do to rectify the gio issue.

  7. #7
    Daveski's Avatar
    Join Date
    Apr 2009
    Location
    Franklin,WI
    Posts
    488
    Called dealer today, They might get to it tomorrow

  8. #8

    Join Date
    Mar 2008
    Location
    mississippi
    Posts
    510
    +1
    1
    Your the first one I have ever heard of GIO in a 15f. I have a 07 with about 37 hours on it and done nothing but changed oil and put in a new set of plugs. How did it go with the break in??? see any issues?? good luck bud .. like i said your the first one to raise that question with a 15f.

  9. #9
    Daveski's Avatar
    Join Date
    Apr 2009
    Location
    Franklin,WI
    Posts
    488
    I am the first one Ive heard of too. Break in went fine, no issues, runs great, just rising oil level and smells of gas. Dealer hasnt called back yet.

  10. #10
    Daveski's Avatar
    Join Date
    Apr 2009
    Location
    Franklin,WI
    Posts
    488
    Picked ski up from dealer today, gas tank fine, as for gio they did compression leakdown test and said it was fine, I am now assuming that my rings werent seated yet, When I bought it last fall I only put seven hrs on it before winter so I changed the oil and put in amsoil. Ive heard it can take longer for rings to seat with synthetic oils, so I guess all is well! Glad to have it back for the holiday weekend

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. maxi rpm for stx15f
    By cedric15f in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 11-23-2007, 02:14 PM
  2. intake grate and pump question stx15f
    By firehawk in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 09-12-2007, 10:12 AM
  3. intake grate and pump question stx15f
    By firehawk in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 09-10-2007, 08:50 PM
  4. STX15F Pump Wegde
    By baldguy50 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 11-26-2006, 10:16 AM
  5. STX15F Mods
    By baldguy50 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 11-23-2006, 05:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •