Results 1 to 8 of 8
  1. #1

    Join Date
    Feb 2006
    Location
    EAST COAST
    Posts
    1,168
    +1
    25

    Im so disappointed!!!

    Well i finally got to test my ski today with the new (SS grate)last year when i put my ski up for the winter it was turning about 7220-7240 and running consistant 78-78.4 with the R&D 1200 grate,,,in the last few weeks i have installed a brand new transom plate and pump shoe,,used 5200 and cleaned with muratic acid to etch,ive did everything that i have read on here to do to have a fast ski,,,to make a long story short my ski is now turning 7200 rpms,, all day today!! but i could`nt get past 75.0 mph with this new SS 800 GRATE!!! im putting my 1200 grate back on tomarrow and removing the impeller nose cone like i was running before to see if my speed comes back! if it dont then i guess once again i have installed the pump shoe out of whack,,anyways i have decided im done with gpr`s,,im selling it no matter if speed comes back or not.i may part it out it has the best of everything but im going to let it go cheap.


  2. #2
    YudLuz2's Avatar
    Join Date
    Jun 2005
    Location
    Flowood MS
    Posts
    1,648
    +1
    111
    I would try some back to back runs with both grates. You should not loose any speed with the SS grate verus a 1200 for sure.

  3. #3
    RHeller1's Avatar
    Join Date
    May 2008
    Location
    Minnesota
    Posts
    192
    been eating alot last winter???

  4. #4

    Join Date
    Feb 2006
    Location
    EAST COAST
    Posts
    1,168
    +1
    25
    Quote Originally Posted by YudLuz2 View Post
    I would try some back to back runs with both grates. You should not loose any speed with the SS grate verus a 1200 for sure.

    I was expecting to pick up at least 1-1.5 mph going from the 1200 to the 800 grate!!!!I should have just left the pump shoe and transom plate alone and just tried the new intake grate.reason i think its the pump shoe is when i put my ride plate on and slide it all the way back there is a definate difference in the gap between the plate and the pump shoe.this tells me the pump shoe is crooked to one side but it dont look like it!!! i do know the transomplate and pump shoe line up perfectly straight in the rear if you look at them with the pump and 2 inch spacer removed from the ski.when in stalling the pump shoe i started all the bolts in and then pushed the shoe allthe way back as far as the bolts would allow then tightened everything up.both times ive did this there is always so much sealant coming out around it i couldnt tell if it were straight or not!

  5. #5
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Winter air temps also provide better speeds...

  6. #6

    Join Date
    Feb 2006
    Location
    EAST COAST
    Posts
    1,168
    +1
    25
    Quote Originally Posted by SHOBiz View Post
    Winter air temps also provide better speeds...

    last year it was 96 degrees and 100% humidity when i was running 78`s all day!! im convinced i screwed the pump shoe up when i put the new one in.the ride plate and shoe have an uneven gap when i slide the rideplate all the way back. im not removing it again when i took it off last week it was destroyed plus it pulled the gel coat off at the transom and the pump shoe!!! screw it!!

  7. #7

    Join Date
    Feb 2006
    Location
    EAST COAST
    Posts
    1,168
    +1
    25
    Quote Originally Posted by RHeller1 View Post
    been eating alot last winter???
    actually i am about 20lbs lighter!!!

  8. #8

    Join Date
    Feb 2006
    Location
    EAST COAST
    Posts
    1,168
    +1
    25
    Well, i got most of my speed back with a few minor adjustments,first i took a screw driver and wedged it between the hull and front of the intake grate and pushed it as far back as i could, then tightened it down.i also removed the impeller nose cone!!! that is all i did today with the new SS grate.i have not ground it to match the shoe nor have i shimmed it down,, today i ran 77.5 - 77.8 at 7240-7260 rpm`s so i gained 2.8 mph just by shifting the grate back and removing my nose cone.i feel a lil better now im going to do back to back test with my 1200 grate next..I will say this about the SS grate it stays very hooked up in the slop,,i had 6"inch to 1 foot cross chop all day and it never missed a beat,felt like a 1200 grate to me,,,now if i can just squeeze another 2.5 mph out of my ski i will be happy.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. im so lost with this PEMP pls help cant tell year
    By hotstrick in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 08-06-2014, 08:36 AM
  2. Im so sick of this!!!!!!
    By WATER WOODY in forum Yamaha PWC Performance (2-stroke)
    Replies: 26
    Last Post: 10-30-2008, 04:10 PM
  3. Boo Hoo, so disappointed......
    By xcduetester in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 04-19-2006, 08:06 PM
  4. so im new, tell me the basic mods on the rxp please
    By flyn ryan in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-19-2006, 07:21 PM
  5. So im going to Vegas in 1 week
    By Pettee in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 11-11-2005, 04:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •