Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77

    What problems have you had with your RXP-X?

    What sorts of problems have you seen with your RXP-X?


  2. #2

    RXP-X

    Blown motor...... Only running 15psi.rr ecu,and rr 4224 cam and kaboom.running same setup on rxp and still going strong at 100hrs.also broken timing chain.

  3. #3
    Quote Originally Posted by GMONEY View Post
    Blown motor...... Only running 15psi.rr ecu,and rr 4224 cam and kaboom.running same setup on rxp and still going strong at 100hrs.also broken timing chain.
    With those mods the exact same thing could happen on any 4tec. Expect to have issues with those setups. Pay to play.

    Jarrett, the issues I read about when the X first came out was the exhaust hose popping off and sinking the ski. Talk to Franko about that one. I believe SD has resolved this issue. Another was something in the engine compartment rubbing on what I believe was one of the IC hoses and causing a boost leak. Again, I haven't heard of this issue since the ski was first released to I assume SD has taken care of it. Though SD got rid of the ceramic washers the metal washers they use have also been prone to failure. There are a couple threads on them cracking. SC's still have their typical issues, though those issues have been reduced some. I dont hear of as many major failures that we were hearing about back in 2004-2007. Have also read about a couple cases of hull delam issues. This is not common though. Just dont beach the ski or run into things. Bucking seemed to be an issue when it was first released, but that was with modded stock grates and speeds in the upper 70mph to 80mph range. Most of the X testers like jawz, JD1, etc. will tell you to not chop the throttle. Jerry found that chopping the throttle on his stock grate FZR would cause the ski to buck, so don't do that on these new skis with larger pump intakes. Other than all that I can't really think of anything. Like was said above every once in awhile you hear about a 4tec snapping a timing chain or dropping a valve, but since 2004-2005 you don't hear about it as much. Carbon seal is still a wear item and when it goes out is a huge issue. Personal preference on keeping that setup or upgrading to something like the rad4 seal. I'm sure others will chime in with all their troubles.

  4. #4
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    Thanks Rex, that's the kind of stuff I was looking for.

    I should have mentioned in my original post that I was talking about stock RXP-X's or near stock. I'm aware of all the issues that can arise once you start cranking up the boost, but that is with any engine.

  5. #5
    mstennes's Avatar
    Join Date
    Jul 2006
    Location
    On the Columbia River above a Dam
    Posts
    843
    +1
    1
    I had mine updated for the hose issues when it went in for its first service (on the dealers dime), I did have the IC hose come off a month ago from the SC to the IC. Wasnt sure if it wasnt tight enough though from the service or from the factory. I did tighten the crap out of it, and have not had any issues since (knocking on wood) On a friends PX, I noticed that none of the hoses on the exhaust or IC were as thight as they should be, in my opinion. I would check all of them before the ride.

  6. #6
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    I think I remember hearing about some early x boats having issues with piston ring failure or excessive ring wear with low hours.

  7. #7
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    Quote Originally Posted by dhoad View Post
    I think I remember hearing about some early x boats having issues with piston ring failure or excessive ring wear with low hours.
    Mostly interested in first hand experience, thanks though.

  8. #8
    My only problem after 40 hours is not getting to ride it enough. It's a great ski, so was my 04 RXP that I put 275 hours on. No trouble.

  9. #9
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    mstennes and dave, thanks thats good stuff. I'm trying to be proactive and head off any issues ahead of time.

  10. #10
    08rxpx's Avatar
    Join Date
    Apr 2008
    Location
    Miami-Dade
    Posts
    20
    My biggest problems were exhaust and supercharger hoses popping off. My only other recall has been my fuel hose was too close to my steering wire (all that was needed was a tie wrap). Other then those couple of things, the ski is awesome. Mines is bone stock hitting 70.4 mph.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha FX HO or similar What problems have you had?
    By nowornever in forum Yamaha PWC Performance (4-stroke)
    Replies: 19
    Last Post: 03-16-2014, 05:11 PM
  2. What boost are you seeing with your C3 wheel?
    By MPower in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 08-24-2010, 06:08 PM
  3. What not to do with your RXP
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 60
    Last Post: 01-14-2010, 10:20 PM
  4. Sea Doo GTI Four Stroke What problems have you had?
    By nowornever in forum 4-Tec Performance
    Replies: 21
    Last Post: 02-04-2009, 10:52 AM
  5. What Computer Problems Have You Had?
    By MaxMike in forum Open Discussion
    Replies: 111
    Last Post: 03-22-2008, 06:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •