Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: Super problem

  1. #1

    Super problem

    Hi all:

    Looking for some suggestions...riding the ultra this weekend and at wfo noticed a power loss...backed down to idle...hit the nearest beach sand and pulled the cover...everything looked fine...so I powered back up ...same problem.....ski runs fine untill the boost comes on...will run fine at 4000prm if you don't stab the throttle....if you stab the throttle the boost gage reads 12lbs. for a few seconds and it feels like full boost but then it looses rpm....as I rode back to my trailer there wer momemts of boost up to 6000rpm and then no pwoer.....is this charger smoked? btw the belt was the 1st thing I checked...cover is on but I can feel the tension is fine.....no I did not spray anything that would cause slippage...

    I guess I just don't know how these chargers fail....ski has 100hrs....changed the s/c oil at 75hrs...only fogged once.


    Any thoughts would help...I do have a extened warranty but if it not covered I'll be turning wrenches...

    I did search other threads...did not see an answer...I know you guys get tired of the same ole crap!


  2. #2
    Check the relief valve that has 1/4" going to the intake manifold. It is hold in by zip ties, see if it is still on.

  3. #3
    2005 RXT Red08Ultra250's Avatar
    Join Date
    Feb 2008
    Location
    Dunedin, FL
    Posts
    908
    How bout the plugs? Airbox intake loose and sucking up against the hull?

  4. #4

    Join Date
    Aug 2007
    Location
    Boonton, NJ
    Posts
    4
    mines has 96 hrs on it and its the supercharger

  5. #5
    benjahw benjahw's Avatar
    Join Date
    Jan 2008
    Location
    Naples, Fl
    Posts
    467
    +1
    30
    also could be a loose airhorn. its been knows to loosen up and suck onto the side at higher rpm causing a loss of power. until you let off the throttle. sounds like a really good possibility to me.

  6. #6

    not the plugs

    Quote Originally Posted by Red08Ultra250 View Post
    How bout the plugs? Airbox intake loose and sucking up against the hull?
    ...thanks for the air box idea Red...

  7. #7

    I need relief

    Quote Originally Posted by creativepuzzle View Post
    Check the relief valve that has 1/4" going to the intake manifold. It is hold in by zip ties, see if it is still on.
    ....I'm not so lucky....hose is on ...thanks..

  8. #8

    Join Date
    May 2007
    Location
    Orange County, CA
    Posts
    201
    Faulty/sticky bov or relief valve?

  9. #9
    benjahw benjahw's Avatar
    Join Date
    Jan 2008
    Location
    Naples, Fl
    Posts
    467
    +1
    30
    Check out the Air Horn thing. Here is a pic. or a Link, Air horn is # 14073. becomes loose and sucks onto side of the craft. u can check it behind the ecu compartment.

  10. #10
    benjahw benjahw's Avatar
    Join Date
    Jan 2008
    Location
    Naples, Fl
    Posts
    467
    +1
    30
    hmm.. cant get the picture.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem with Riva Super-Duty ‘GEN-3’ Supercharger Shaft Kit
    By gsm_dm in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 04-05-2013, 09:33 PM
  2. Super charger clutch problems!
    By 2fast4u in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 01-31-2011, 04:06 PM
  3. Can Oil cap cause super charger problem?
    By immred in forum 4-Tec Performance
    Replies: 16
    Last Post: 09-19-2009, 09:04 PM
  4. Super Charger problems
    By rocksteady in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 08-13-2008, 08:26 AM
  5. Super charge clutch problem
    By Woody49 in forum 4-Tec Performance
    Replies: 9
    Last Post: 11-21-2006, 09:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •