Results 1 to 3 of 3

Thread: 95 Spx's

  1. #1
    SHO What????? jpack's Avatar
    Join Date
    Jan 2007
    Posts
    720
    +1
    1

    95 Spx's

    A friend of mine picked up a pair of them. When he took them out for the first ride he said they would sputter then take off like a rocket. As soon as you hit the gas again they would sputter again like they weren't getting any gas. Any idea's where to start. Would the fuel pump run intermittently?

    Jim


  2. #2
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    hes probably still got the grey fuel lines. if so he needs to change them out and clean the carb filters. if they still have the grey lines and he doesn't change them and clean those filters, he will run it lean and kill the pistons.

  3. #3
    SHO What????? jpack's Avatar
    Join Date
    Jan 2007
    Posts
    720
    +1
    1
    Thanks I'll have him check...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gas guage not working 95 SPX
    By CrazyClam in forum 2-Stroke Performance
    Replies: 3
    Last Post: 06-26-2008, 09:16 PM
  2. 95 Spx problem
    By eclipsecleaning in forum 2-Stroke Performance
    Replies: 2
    Last Post: 09-26-2007, 07:54 PM
  3. Wear ring on a 95 spx 657
    By gvnitup in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-07-2007, 12:42 PM
  4. 95 SPX Water in Hull
    By 95 sl750 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 05-11-2007, 10:04 PM
  5. 95 spx electrical question
    By 95 sl750 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 04-17-2007, 08:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •