Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    My Cruise with Rodney (TNrxp)

    First off THANKS again Randy (TenneseeRXP) for helping with my Riva SC and the 05 washers and hanging in there with me during my wrenching in the water

    We went cruising down the Old Hickory lake it was around 95 air/ 85 water and 60% humidity. Water in some spots would shift to 75 but not for long. After getting in the Riva SC and metal washers we hit the water. Right off the bat my ski drops down to 4000rpms and I almost sh*t my pants. I lift the back seat and my rear intake had sucked the bubble wrap around the outwears pre-filter. I used the bubble wrap as an engine air seperator. I'm now going to switch back to the tube since my intake has that extra sucking power. Then we get to cruising for about 10 more minutes and I can't get over 7600rpms. We pull over and I spend about an hour balanced on the back of my ski in the 95 heat trying to wrench on my ski. Holding tools while wakes come by. Ends up being my SC to IC tube blew off. Meanwhile the wakes have pushed me onto an island which I bounce a tree trying to leave. Finally 8050 rpms and pulling like a train (for me). Then we stop and I do some spin outs and suck up a stick. Usually I can spit it out but this stick is spitting out wood chips !!
    Rock the boat, spin out and finally I'm good. Then we see some other skiers and I try to pull next to them and I suck up another stick and this one I can't shake loose. It's sticks with me all the way to 7900rpms. Finally shake it loose and we are off to the glass!!!

    What's funny is in flat water , pretty straight shot. His stage 1 RXP was nose to nose with my stage 2 RXT. I'm talking like EXACT same. We were flying about 2 feet from each other on glass water and trying EVERYTHING to nose in front of each other. sliding back/forth, ducking handlebars. I was able to get to 69.7 (had skegs too) and normal riding was right around 69. I still have some tweaking though because at the end of the day I noticed silicone all over my skegs (thought it would remove).

    We cruise back and my engine light goes on. Randy tells me I have about 20miles left and 4 gallons so off we go. I cruise at about 5000 rpms and have to watch everyone else jumping waves and flying by but I make it. When I transfer my gps data I'm going to figure out the exact distance I made. We get back, fill up and drop back in next to party cove and do some racing around chilling out.

    It was a good day

    Next time maybe we can get SHHR along for the ride.


  2. #2
    RustySeaRustyDoo's Avatar
    Join Date
    Oct 2005
    Location
    Chesapeake Bay-Pasadena, MD
    Posts
    1,788
    Sounds like fun! Wrenching on the ski in any temp sucks. Glad to hear you werent down for the day...

    When are you going to hit that 70 mark?

  3. #3
    Quote Originally Posted by RustySeaRustyDoo
    Sounds like fun! Wrenching on the ski in any temp sucks. Glad to hear you werent down for the day...

    When are you going to hit that 70 mark?
    Hopefully next time out. My skegs had silicone all over them which I didn't think would stay. Also need to clean the bottom of my hull it had metal dust all over it which I didn't think would stay either. I'm going to redo my plumbing with a BOV so should get ALL the leaks. If I can get another 50rpms I'm going to bend out a mm, which would be nice. I also need to put on a aftermarket exhaust which I would hope would give me at least 50rpm. We are in peak heat so I'd like to get it dialed now.

    I feel pretty good with being able to go head to head with a stage 1 rxp in glass and get a boat on it in holeshot. Should be able to get a good run past a stock rxp, especially in the heat.

    Also going to fix up my intake which was pulling engine heat this time around. I'm going to put the tub back in a seperate the engine/outside again.

    My skegs are 1/16th off at the VERY back so that is my last resort. Also going to try that seaslide hull wax stuff and mess with splitting my IC line.

    Randy also said he was pulling 72 in mudbug and I was head to head with Randy in glass. So I think the 500ft altitude might be effecting me a little, not sure what mod would fix that besides some Uhaul trucks and long ride.

    All this should get me .3

  4. #4
    RustySeaRustyDoo's Avatar
    Join Date
    Oct 2005
    Location
    Chesapeake Bay-Pasadena, MD
    Posts
    1,788
    Sounds like if you get all your little issues cleaned up, you be there no prob.

    Good luck. Dont forget to make that Finally hit 70 post...
    Last edited by RustySeaRustyDoo; 08-07-2006 at 11:49 AM.

  5. #5
    Do Work Son 05RXPnoob's Avatar
    Join Date
    Jul 2005
    Location
    Lake Chickamauga/ Chattanooga TN
    Posts
    958
    Man I would like to go riding around there sometime. . . maybe we can organize a mini-TN get-together?

    Jay

  6. #6
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    Kinch

    that sound like a good day I was cutting the dead weeds in my yard where the grass was before this heat killed it,

    I will be ready to go after Wednesday for a little test run as I forgot to order the prop tool and the dealer wont have any until Wednesday

    how about a little test ride Thursday afternoon

  7. #7
    I don't get off work until 5pm. This weekend I think we are going to cruise around Piercy Priest and maybe check out all the beaches.

    What all do you have left on yours to do Shhr ? I'd like to the difference between ours when you get finished.

    I just realized TN area isn't so ski friendly being we have the 95+ air and high 80's water unless you get around a mountain run off. We are also 500 feet above sea level. All the speed numbers from the forums are from the 0 ft elevation range.

    I think any of the other high elevation riders are in the Northern colder areas.

    I think I'm running pretty strong but would like to see next to another modified RXT.

  8. #8
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    I just installed the riva open air and am going to install the 15/20 GH prop, the only things I have left are the Riva Intercooler and the 42lb injectors,

    I am curious to see how I turn the 15/20 before and after the intercooler

    I think you are feeling sick Thursday and need to leave work about 3 then meet me at Old Hickory

  9. #9
    Quote Originally Posted by shhr
    I just installed the riva open air and am going to install the 15/20 GH prop, the only things I have left are the Riva Intercooler and the 42lb injectors,

    I am curious to see how I turn the 15/20 before and after the intercooler

    I think you are feeling sick Thursday and need to leave work about 3 then meet me at Old Hickory
    I wish, I'm in the middle of a bunch of crude though I have to finish this week. 15/20
    I bet you won't be able to turn the prop before the IC. You will probably be at 7600-7700rpms (with the RR wheel). I wouldn't waste your time with trying.
    I bet your even going to have to pull out a mm or 2 after the Riva IC and injectors.

    What are you going to test on Thur ?
    the riva and 15/20 without the IC ? You're going to be in early

  10. #10
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    I do have a repitched stock prop that Jeff sent me. I may put that in first and wait on the 15/20 I wish I had a 14/19 to try

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Raced my Ultra with my RXT
    By Antiguan FZR in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-13-2007, 03:23 PM
  2. Sharing a few pics of my wedding with you guys...
    By GeoRXT in forum Open Discussion
    Replies: 31
    Last Post: 04-30-2007, 09:45 PM
  3. Tested my ski with no cone
    By Hecyan in forum 4-Tec Performance
    Replies: 26
    Last Post: 07-24-2006, 11:26 AM
  4. My results with my new intake and 102*
    By Water4fire in forum 4-Tec Performance
    Replies: 17
    Last Post: 07-12-2005, 08:49 PM
  5. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •