Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    Did my RXT die?? please help!

    I have a 2005 RXT with about 50 hrs on it.. I ride it only in salt water.

    So it was working fine.. i am in the middle of the bay and i accelerate and I hear a horrible sound like crushed bearings going around and a serious vibration. I had to go all the way back in idle... when i accelerated a little (3k RPM) the crushing bearing sound was awfull... i accelerated a little more (4-5k RPM) and the whole machinse started vibrating.. I accelerate a little more than that (7k rpm) and it would stop vibrating as much but it would not go forward very fast at all...

    so any clue as to what i destroyed on my machine?? Im thinking its the SC clutch...

    how much should this cost me to get fixed? any help will be greatly appreciated.


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,531
    +1
    1,283
    have a look into your ride grate or pump, I'd bet you have a hundred yards of fishing line , lures and what nuts bouncing around in there, or your pump bearing are gone and the drive shaft has stripped the prop splines out.

  3. #3
    Banned User
    Join Date
    Aug 2007
    Location
    Reading PA
    Posts
    1,670
    well when the SC goes it normally doesnt rev up over like 6400 to 6800 rpms, simple check is pull the hose going from the SC to the TB and see if u can spin the SC wheel by hand if u can then ur in trouble and depending on a few things depends on how much it will cost.

  4. #4
    I looked in the grate and had some algea but not much and i removed it... once i removed them and flushed the engine the sounds were not as horrific and there was no vibration.. but i thought it was because the machine was not in the water having to go forward...

  5. #5
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    809
    Sounds like a driveline issue. Is there any water in the hull? I wouldn't go far from the ramp until you figure this out. If your carbon seal is going bad you will sink your ski.

  6. #6
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    I have seen a charger impeller come loose on an RXT 07.

    Sounded horrible as well.

  7. #7
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    809
    Quote Originally Posted by Richieb View Post
    I have seen a charger impeller come loose on an RXT 07.

    Sounded horrible as well.
    Maybe the supercharger bearings are on the way out and the sound he's hearing is severe touchdown. It gets louder as the RPM increase because the wheel is spinning faster.

    Take your air intake hose off and look for metal shavings and check to see if the wheel can spin by hand.

  8. #8
    Thank you thank you to everybody who is responding to my questions..

    there was no water in the hull watsoever...

    so it is either driveline problems or supercharger problems then?

  9. #9
    KC Blue Thunder's Avatar
    Join Date
    Oct 2007
    Location
    Jacksonville, Florida
    Posts
    2,079
    Like brother james said disconnect the going to the S/C and check to see if the prop spins. Have you had the ceramic washers changed on it?

  10. #10
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,019
    +1
    308
    Quote Originally Posted by droquette View Post
    Thank you thank you to everybody who is responding to my questions..

    there was no water in the hull watsoever...

    so it is either driveline problems or supercharger problems then?
    Probably not your issue, but... mine vibrated real bad like that once - turns out it was a gouge in the wear ring. I was in deep water too. Mine was prob. a small piece of gravel picked up and lodged from the boat ramp and then came loose when out on the water. If it isn't your SC, then you might want to check your wear ring.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bloody CAVITATION with my 09 sho (Please help)
    By fmxjce in forum Yamaha PWC Performance (4-stroke)
    Replies: 12
    Last Post: 10-11-2010, 09:33 AM
  2. tired of my ski breaking PLEASE HELP DIGANOS
    By mfdkhoff261 in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-07-2010, 01:42 PM
  3. 2008 RXT or 2008 RXT-X??? Please help
    By chuckbatts in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-24-2010, 02:49 PM
  4. Trim problem on my XP 800.Please help before i smash it
    By TMPLUMBER59 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 08-16-2009, 10:44 AM
  5. My rxt died yesterday
    By AdrianRXT in forum 4-Tec Performance
    Replies: 22
    Last Post: 07-10-2009, 01:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •