Results 1 to 10 of 10
  1. #1

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7

    venture 1100 loading up at idle

    had the venture out today, i noticed if it idles for a while, it feels like the carbs load. then if i get on it, it bogs for a little while. it seemed to do this when driving at low speeds sometimes also, a quick WOT blast would usually clear it out. is there an adjustment for this, or is it just because of all the oil getting dumped in by the injection system?


  2. #2

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7
    do these things come set rich from the factory? im thinking maybe because it only has 37 hours on it, it wasnt tuned after break-in? also, do the 1100s have the same carbs as the raider 701?

  3. #3
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170
    The carbs are different because your's has a remote fuel pump where the other 701's have 44 carb and or dual 38's with one of them having the pump...the other slave. It's possible that your just need to adjust the needles back to stock and use a good tach to get the mixture set right.

    M

  4. #4

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7
    so this ski doesnt have mikuni super bns on it? which carbs does it have? what are the stock settings for the needles? i still need to print out the service manual. it isnt possible to adjust them without removing them is it?

  5. #5
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170
    Yup SBN carbs....but a remote fuel pump. Look for that pump...you will see the pulse lines going to it

    M

  6. #6

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7
    i guess i will drive it this way for the rest of this season, then once i have it inside for the winter, i will adjust it back to stock settings. im also planning on rebuilding the carbs in this ski and my raider, just so i know its 100% done. im actually a little skeptical about opening these carbs, they seem very complicated compared to the banshee carbs im used to working on, i might just have island racing rebuild them. the diaphram thing is what im worried about.

  7. #7
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170
    Carbs are basic....real basic and they are actually easier then the 350's twin carbs. The most bitech about doing them is scraping off the pump cover gasket when you replace it. Take your time...do only 1 at a time and you will have ZERO problems!

    M

  8. #8

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7
    well i found the stock settings, 1 1/8 of a turn out on the low speeds, that sounds pretty impossible to do without removing the carbs!

  9. #9
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170
    get a dime in there and turn them....not that hard man...put some effort into it!

    M

  10. #10

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7
    Quote Originally Posted by Mpeavler View Post
    get a dime in there and turn them....not that hard man...put some effort into it!

    M

    o man for some reason i was thinking they were philips heads. i have no clue why lol. ok cool so i just need to go pick up a digi tach tomorrow.

    thanks for all the help with these skiis btw, i really appreciate it!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. loading up at low rpms
    By speedy9913 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 09-08-2013, 08:52 AM
  2. 1100 Waveventure smokes at idle,long crank warm
    By autowizzard in forum Yamaha Old School Skis
    Replies: 11
    Last Post: 07-15-2012, 10:09 PM
  3. Idle adjustment screw on 97 wave venture 1100
    By sortsol in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-11-2011, 09:57 AM
  4. 1996 Polaris SLX 780 breaking up at full load, hmmmm?!?!?
    By TechSLX in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-15-2008, 09:31 PM
  5. loading up on idle
    By alex29573 in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 05-12-2008, 08:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •