Results 1 to 8 of 8

Thread: no vts HELP!

  1. #1

    no vts HELP!

    my ski was working fine when i put it on the trailer. i changed my wear ring. and now my vts does not display. it flashes sensor on the display. and it says 0.0 ft when you scroll through the modes. it has never said that. HELP!


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by jake2582 View Post
    my ski was working fine when i put it on the trailer. i changed my wear ring. and now my vts does not display. it flashes sensor on the display. and it says 0.0 ft when you scroll through the modes. it has never said that. HELP!
    Off to the dealer you go Another victim of ECU memory loss... the dealer will need to activate the vts with the BUDS software program

  3. #3
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Quote Originally Posted by jake2582 View Post
    my ski was working fine when i put it on the trailer. i changed my wear ring. and now my vts does not display. it flashes sensor on the display. and it says 0.0 ft when you scroll through the modes. it has never said that. HELP!
    My ski has been at the seadookie dealer for 5 weeks, same problem you described, but mine has phantoms, lost VTS and display , ski cuts off by itself. Tech says he put new DDS post on, but problem comes back. I can only guess ECU? battery good, voltage regulator good, stator good, VTS motor good? What the heck can it be?????????

  4. #4
    Quote Originally Posted by bigdaddyRXP View Post
    Off to the dealer you go Another victim of ECU memory loss... the dealer will need to activate the vts with the BUDS software program
    how? i didnt even disconnect the battery. could i have messed up the dss motor or something taking the pump off?

  5. #5
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by jake2582 View Post
    how? i didnt even disconnect the battery. could i have messed up the dss motor or something taking the pump off?
    Don't know, don't know... and No!

  6. #6
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,282
    +1
    2
    Mine was as simple as a bad connection at the ECU, check all your connections and make sure all the pins are in good shape!

  7. #7
    Quote Originally Posted by bigdaddyRXP View Post
    Don't know, don't know... and No!
    Static electricity ya have to ground things now when you start working on your ski.

  8. #8
    Quote Originally Posted by Pirates81 View Post
    My ski has been at the seadookie dealer for 5 weeks, same problem you described, but mine has phantoms, lost VTS and display , ski cuts off by itself. Tech says he put new DDS post on, but problem comes back. I can only guess ECU? battery good, voltage regulator good, stator good, VTS motor good? What the heck can it be?????????
    Your ski was haunted to begin with Ya need a Priest and some Holy water and not a Sea Doo dealership

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 07-01-2013, 02:17 PM
  2. NO SPARK help
    By Lvnspeed in forum 4-Tec Performance
    Replies: 24
    Last Post: 02-09-2007, 08:59 PM
  3. Ski Is Glued To The Water (no lift HELP)
    By Mik72e in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 01-07-2007, 11:05 PM
  4. R&D grate Defective or no problem??? Help...
    By Tiburon in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-24-2006, 06:45 PM
  5. No Spark Help
    By mt375hp in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-27-2006, 04:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •