Results 1 to 9 of 9
  1. #1
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128

    Boost - stuck at 7 lbs no matter what ...

    I have a 2005 RXP, put a boost gauge on it while still relatively stock. Initially measured 7 lbs of boost with a RR intercooler and stock supercharger. Swapped to a Riva intercooler this year, still shows 7 lbs of boost. Swapped to my Les Cook A kit supercharger, still showed 7 lbs of boost. Deformed a crappy Riva IC tube, had a boost leak. Had 2.5" muffler pipe bent up, flared ends to 2.75", boost is solid and stable again, but still only 7 lbs on gauge at 8100 rpms, stock ECU.

    Ski is a Riva stage 2 and runs 75 - 76 mph GPS, runs strong, but I gained nothing from the A kit supercharger ... no additional rpms, no additional boost on the gauge. I also replaced my intercooler blockoff with the Riva one and tightened it up.

    Just a little curious ... thought I would see more like 9+ lbs of boost with the A kit (looks very much like the RR impeller) and the Riva intercooler. The A kit is brand new, metal washers, no slipping, just curious why I am not seeing more boost and a gain in top end rpms ... everything works great, no alarms, no problems, very steady rpms and boost, just was thinking there should be more ... ideas?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    What kind of gauge?

  3. #3
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    It is a VDO mechanical gauge, boost only, 0 - 15 lbs. Very simple, very easy to read. I would suspect the gauge too, except the A kit supercharger did not seem to add any additional rpms on top either; rpms and speed are the same as with the stock supercharger. Now wondering if I still have another boost leak somewhere, but more a crack rather than a fitting that leaks intermittently. Still, the boost and rpms are now rock steady and performance is good, just anticipated more boost and at least 100 rpm increase from the better supercharger impeller ... just puzzled ...

  4. #4
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    what kind of air intake?

  5. #5
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Still the standard Riva air intake, no other air mods. But I ran with the seat completely off and boost was still the same 7 lbs too ... I usually gain 1 mph, but boost is the same ...

  6. #6

    Join Date
    Jun 2005
    Location
    rome ga
    Posts
    938
    +1
    20
    Probably bad guage or pinched hose to guage.
    a kit 10lbs @8600 [email protected] [email protected]?

  7. #7
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    It might be that. I ordered a boost leak tester from www.siliconeintakes.com and will also double check that the intake nipple is fully drilled and open and that the gauge hose is fine. Maybe the intake nipple is not cleanly drilled out, will double check.

  8. #8
    Quote Originally Posted by Vern
    It might be that. I ordered a boost leak tester from www.siliconeintakes.com and will also double check that the intake nipple is fully drilled and open and that the gauge hose is fine. Maybe the intake nipple is not cleanly drilled out, will double check.
    please post when you get that leak tester going. I'd like to get one.

  9. #9
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Will do, they are only $30, was quicker and easier to buy one than for me to try to fab one up. Should be able to test this weekend.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. X-SC sitting at 102in/lbs. What's needed?
    By imp0ster in forum 4-Tec Performance
    Replies: 17
    Last Post: 07-24-2013, 06:46 AM
  2. Replies: 30
    Last Post: 01-12-2013, 08:05 PM
  3. Can't get RPM's over 7600 no matter what we do on an 09 Ultra 260x
    By Jordan #94 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 07-24-2011, 09:13 AM
  4. WTB Need rxp hull no matter what shape
    By RXP2 in forum Sea Doo Classifieds
    Replies: 14
    Last Post: 06-05-2010, 09:35 PM
  5. Stuck at 8,000 RPM"S. ??????????
    By 4-techscharger in forum 4-Tec Performance
    Replies: 64
    Last Post: 07-08-2007, 02:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •