Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    HELP!! did i blow it up??

    I have an 05 rxp and i just put in a stage 1 and a rr SC wheel. Went out for a test ride today and had a few WOT runs and no problems. Started doing some donuts then i find i lost rpm and can't get to 7000 and have a ton of blue smoke behind me. not a good situation. any body have any ideas where i should start or possible causes?


  2. #2

    Join Date
    Jul 2009
    Location
    Stonington, CT
    Posts
    151
    Are your coolant or oil levels going down?

  3. #3
    Quote Originally Posted by JR4 View Post
    Are your coolant or oil levels going down?
    coolant no but oil im assuming considering the blue smoke it must be burning it somehow. i can't ride it to find out how much oil its consuming. im thinking a blew a piston. only has 23 hours on it

  4. #4
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    How many PSI wheel was that? DId u up grade the injectors? If not than u probably ran lean, and melted a hole in the #3 cyl (back one) I would do a compression test to see where your at? Did it start to miss pretty bad, while it was smoking? Check for oil on the plugs also.

  5. #5
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722
    I am reading this as Stage 1... so you have the 14/19, Air intake and intake grate..... Did you add anything else other than the RR Wheel? And by RR you mean Rotax Racing wheel or the Riva Gen I or Gen II wheel?

    With the stock IC... he shouldn't have had to upgrade the injectors.

  6. #6
    Quote Originally Posted by 04RXP22 View Post
    I am reading this as Stage 1... so you have the 14/19, Air intake and intake grate..... Did you add anything else other than the RR Wheel? And by RR you mean Rotax Racing wheel or the Riva Gen I or Gen II wheel?

    With the stock IC... he shouldn't have had to upgrade the injectors.
    exactly the rotax wheel. not much extra boost. wasn't missing at all when smoking. just no power and a ton of blue smoke. i wouldn't have thought a stage 1 would cause a problem unless i screwed somethign up. would hitting the rev limiter while doing donuts cause this issue. i have done it many times before with a stock ski

  7. #7
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    Blue smoke not good, but check the intake elbow pipe inbetween the charger and throttle body. I split mine in half today, and couldnt get it over 7000rpms, didnt have any smoke but you never know.

  8. #8
    Check your compression. Also could have blown the SC to IC pipe off and runing rich.

  9. #9
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    2 words, Compression Test! to rule out the cylinders just do this and you will fell better, well thats if your compression is good
    when you do it just go from the front to back, so that way when the last cylnder is tested you can say WOHO!

  10. #10
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109

    i dont think so....

    sounds like the S/c shaft oil seal,its sucking your oil from the engine.install a complete S/C rebuild kit. good luck

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help testing info center. how to power it up
    By steelroe in forum 4-Tec Performance
    Replies: 1
    Last Post: 03-19-2015, 08:21 PM
  2. Replies: 9
    Last Post: 06-21-2012, 11:15 PM
  3. Help! water ingestion nightmare. Did I save it or am I screwed?
    By 420kushking in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 10-06-2011, 10:08 PM
  4. Gasket question - HELP ASAP - before the husband screws it up
    By sunshine_n_pc in forum Yamaha How To & FAQs
    Replies: 6
    Last Post: 05-17-2010, 07:30 PM
  5. Check This Stuff Out It May Help Our Oil Blow By Prob Let Me Know What Ya All Think
    By Ultra250xryder in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 09-28-2007, 09:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •