Results 1 to 4 of 4
  1. #1
    Haislip's Avatar
    Join Date
    Jun 2006
    Location
    Nashville/Knoxville TN
    Posts
    27

    So I Installed the Riva Grate...Also Unrelated Problems Inside!

    Didnt notice much difference, except that if I accelerate when I turn it makes a weird noise seemingly from under the ski, its kind of hard to describe... I made sure it lined up correctly, is this sound normal? What does cavitation sound like?

    Oh, and my 20 hour ski barely reaches 7900 rpm, oil level is perfect, but I did suck up a stick the other day and had to trailer the ski and remove the stick...so, did it hurt my wear ring or impeller?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Thats a normal sound in the turns with the grate. Its just something with the hydrodynamics of it.

    Your wear ring is toast and is more than likely the reason your R's are down.

  3. #3
    Haislip's Avatar
    Join Date
    Jun 2006
    Location
    Nashville/Knoxville TN
    Posts
    27
    OK good as long as that sound isn't asociated with the bad news bears...So you've been talking about a stainless ring, should I bite the bullet and go ahead and get it? Do I need anything to make it fit? Thanks for your quick reply!

  4. #4

    Join Date
    Jun 2005
    Location
    Hamilton, Ontario, Canada
    Posts
    556
    I noticed the same after installing the riva grate. I put the stock grate back on to compare and it no longer made the noise when turning. I have no idea as to what is causing this.
    I started another thread a while back about this and a bunch of others encountered the same noise after installing the riva grate.
    The Riva is back on my RXP, as it did not effect performance in a negative way. I meant to check the RIVA site to see if there was any info there related to this.
    check out the other thread. Some poeple had a few ideas as to what it could be.
    http://greenhulk.net/forums/showthre...ighlight=noise

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I just installed the Riva KIT I
    By Impulses in forum 4-Tec Performance
    Replies: 13
    Last Post: 12-27-2012, 05:54 AM
  2. Is the Riva Grate a P.O.S?
    By cjo632racing in forum 4-Tec Performance
    Replies: 22
    Last Post: 07-08-2011, 05:28 PM
  3. RXTX upgrades, very pleased with the RIVA grate
    By dr_hunt in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-09-2009, 09:11 AM
  4. installed the riva sponsons
    By BlaZinMJ in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 03-20-2007, 11:19 AM
  5. How to install RIVA GRATE ?
    By Totallyblown in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 05-30-2006, 11:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •