Results 1 to 5 of 5
  1. #1
    tony4963's Avatar
    Join Date
    May 2007
    Location
    rhode island
    Posts
    35

    thermostat housing

    hi guy i have a t-x an the other day in about 1-2 chop riding for a few hours my boat started skipping an one long beep so i shut it off got it on the trailer at home pulled all the hoses found the thermostat housing pulled apart i never had the housing apart boat has 35 hours on it i put the thermostat back in an pushed it back on took a little to do but got it done should i trust this or get a new water pump housing thanks for your input


  2. #2
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    just put a hose clamp around where the little tabs are to clamp down and if it dont leak It'll hold.

    Did you put a 160* stat in?

  3. #3
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    maybe you were overheating, plastic got soft?? if it snapped together , felt like it snapped in securely, then a clamp around the snappy part will be good.
    but if you think it got really hot, and plastic was softening, figure out why...
    did you reinstall the Tstat????
    theres also supposed to be an o-ring in there.
    make sure you refill your coolant, and check it, burp it, on the trailer.
    is it warrantied???
    if it is i would go to dealer explain what happened anddemand they order a replacement for you and install it.
    but if not, its probably gonna be fine.

  4. #4
    tony4963's Avatar
    Join Date
    May 2007
    Location
    rhode island
    Posts
    35
    thanks guys went out today road for 2 hours an no problems don't know what caused the housing to come apart but its all good now thank you again

  5. #5
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    Yeah I think its just the plastic, when you do a t-stat mod by putting a 160* you have to pour hot water on it to soften the plastic to pull the cone out, I guess it did the same for you but with the heat of the engine,
    Are you running the proper anti freeze to water 50/50?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB: Thermostat housing for an rxp
    By mito lete in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 09-29-2008, 08:22 PM
  2. Seadoo 4TEC Thermostat housing pop off
    By seadoondude in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-05-2008, 02:21 PM
  3. WTB; thermostat housing 4tec
    By dav_dman in forum Sea Doo Classifieds
    Replies: 7
    Last Post: 08-03-2008, 11:05 PM
  4. WTB: Stock thermostat housing.
    By 01xdime in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 06-29-2008, 10:51 PM
  5. Stock Thermostat Housing
    By HOSS in forum 4-Tec Performance
    Replies: 29
    Last Post: 05-09-2006, 03:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •