Results 1 to 4 of 4

Thread: rxp wont start

  1. #1

    Join Date
    Jul 2008
    Location
    ENGLAND
    Posts
    605

    rxp wont start

    i just tried to fire up my ski,and it was runnunig on 2 pots.I removed the lead to the middle coil and it stayed the same runing rough.I thought that the plug was not sparking,as it was still running.I pulled the plug put it conected to the coil and very very briefly touched the starter looking for a spark....it didnt.But now i got no beep when i conect the lanyard,the fuel pump dont run,and it wont turn over,all the display comes up though.I have removed and checked all the fuses they are fine,but in the relay box there is a smaller box that clicks when i attach the lanyard.Ive just charged the battery for ten mins .....i now have all display,beep beep,and fuel pump is working,but when i hit the starter button i get a clunking sound from the fuse box.....any help many thanks


  2. #2

    Join Date
    Jul 2008
    Location
    ENGLAND
    Posts
    605
    after 40 mins charge,the ski starts,and runs fine on 3 pots now.....but when i stop it and try to start it takes 5 or 10 mins charge to get enough for it to fire up.....can a battery be this bad as to start a ski,and then virtually die in seconds.....i was baffeled and thought i had messed up or something...guess i need a new battery.....bloody strange though....anyone else had issues like this?

  3. #3
    baba850r's Avatar
    Join Date
    Sep 2007
    Location
    scotland
    Posts
    673
    +1
    4
    Quote Originally Posted by MARK_LEGG View Post
    after 40 mins charge,the ski starts,and runs fine on 3 pots now.....but when i stop it and try to start it takes 5 or 10 mins charge to get enough for it to fire up.....can a battery be this bad as to start a ski,and then virtually die in seconds.....i was baffeled and thought i had messed up or something...guess i need a new battery.....bloody strange though....anyone else had issues like this?

    yes mate had it with a gtx and an rxp.
    is the battery holding a charge?or is the batter pretty much goosed?
    are you sure your skis charging the battery when its running?

    we had a ski blowing rectifiers and then chewing batterys basically........turned out to be a bare wire.

  4. #4
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    you need more patience!!! a battery needs hours and hours of charging to be any good slow charge it for 10 hours then get it tested. 5-10 mins will give it a small surface charge and thats all

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help 04 Rxp wont start
    By region8racer in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-17-2009, 11:40 PM
  2. Help 04 Rxp wont start
    By region8racer in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-13-2009, 04:52 PM
  3. 06 RXP wont start?
    By Stainless in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-03-2009, 09:09 AM
  4. 06 Rxp wont start
    By Antiguan FZR in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 03-31-2008, 04:54 PM
  5. RXP wont start
    By werdnash2002 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-21-2005, 11:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •