Results 1 to 10 of 10

Thread: Wear Ring Fit?

  1. #1

    Join Date
    Aug 2009
    Location
    San Diego
    Posts
    4

    Wear Ring Fit?

    Okay , I replaced my wear ring but it sticks out of the housing full 1/4" and it seems (to me) because of this when i install it on my ski it is touching the thru way thus my drive shaft does not go all the way in ...should the wear ring be flush with the housing or is the 1/4" the way it is supposed to be? look at the images
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Ring and Shaft.jpg 
Views:	121 
Size:	92.4 KB 
ID:	145149  


  2. #2
    FrankieV123's Avatar
    Join Date
    Aug 2008
    Location
    Florida -JERSEY
    Posts
    260
    +1
    1
    i think that your wear ring should go in farther...plus make sure that impellar is on the shaft seated correctly.

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    They do stick out a bit..Yours looks right..

  4. #4
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4
    Finncolors, slide a long screwdriver into the back of the pump and gently pry on an impeller blade. You probably just need to turn it a bit to line up the splines... Should slide right on.

  5. #5

    Join Date
    Aug 2009
    Location
    San Diego
    Posts
    4
    You have to understand I have taken the pump apart and the wear ring is on all the way and the shaft is on all the way ....I think what im going to do is shave 1/4" off the end of the wear ring this will allow the pump to get closer to the pump mounting bolts thus allowing the shaft to enter in the impeller a little more ....I was just checking to see if the wear ring needed to be flush with the housing ....maybe was given a wrong wear ring maybe too wide. Ill do this and see what happens?

  6. #6
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    The wear ring sticks out a little on my pump, too. I have replaced it twice now. You should be able to push the pump up against the pumpshoe by hand. If you can't you may not be getting the shaft lined up with the prop splines.

  7. #7
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    You know looking at your pictures. The clearance between the prop and new wear ring looks kind of wide. Is that a OEM wear ring? You could measure the distance at the pumpshoe to pump. To see if the wear ring is the right depth.

  8. #8
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by finncolors View Post
    You have to understand I have taken the pump apart and the wear ring is on all the way and the shaft is on all the way ....I think what im going to do is shave 1/4" off the end of the wear ring this will allow the pump to get closer to the pump mounting bolts thus allowing the shaft to enter in the impeller a little more ....I was just checking to see if the wear ring needed to be flush with the housing ....maybe was given a wrong wear ring maybe too wide. Ill do this and see what happens?

    Is your pump not butting up against the pump shoe when torqued down?????If there is a gap between the pump and shoe then i would say there is an issue..You should not have to cut or grind off any part of an OEM wear ring if it is the right one and is installed properly...Of all the wear rings i have replaced they have stuck out about that far..I wouldnt cut that wear ring until you have a spare..If you cut it and it doesnt work your gonna have a 1/4 inch gap in the pump tunnel therefor you will now have a cavitation problem..also if you do that and you put to much pressure on the driveshaft/pop assmbly you could tear up the thrust washers in the motor.

    Me personaly would pull that wear ring back out and reinstall your old one if you still have it and see how that one fitted into your pump..

  9. #9
    That's pretty much where it needs to be As long as you see that the inside end of the ring int eh pump is flush with no spacing then you are fine. The rings stick out that far -- it's normal.



    Quote Originally Posted by finncolors View Post
    Okay , I replaced my wear ring but it sticks out of the housing full 1/4" and it seems (to me) because of this when i install it on my ski it is touching the thru way thus my drive shaft does not go all the way in ...should the wear ring be flush with the housing or is the 1/4" the way it is supposed to be? look at the images

  10. #10

    Join Date
    Aug 2009
    Location
    San Diego
    Posts
    4
    Thanks guys for your input, most helpful. this is a great forum . will be using it in the future. Thanks again

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Wear Ring Doesn't Fit Pump
    By Water Pig in forum Sea Doo Spark
    Replies: 15
    Last Post: 06-04-2014, 05:07 PM
  2. E-bay New Sea doo wear ring quality and fit. $23.94
    By skylolow in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-05-2014, 11:34 AM
  3. New wear ring - impeller won't fit
    By boostedgta in forum Sea Doo How To & FAQs
    Replies: 3
    Last Post: 05-27-2013, 07:54 PM
  4. Stainless steel wear ring fitting
    By rxpsquad in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-14-2011, 04:39 AM
  5. Will the SS wear rings fit the jet boats.
    By DSquare in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 06-25-2007, 09:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •