Results 1 to 3 of 3
  1. #1

    Please please please help!!!

    Can anyone give me the correct fuses for the Digital Display and the Bilge Pump located in the Electrical Box. The ones that came out cannot be the right ones. 1996 Polaris SLT 780. Thanks

  2. #2
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Boulder City, NV
    .25 amp for the mfd and 3 amp for the bilge pump. Radio Shack has them.

  3. #3

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please o please help me
    By freemandino25 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 08-12-2010, 07:58 PM
  2. 1990 SP, very difficult to start. Please read and help troubleshoot.
    By SportbikeRiderXX in forum 2-Stroke Performance
    Replies: 0
    Last Post: 05-28-2010, 05:23 PM
  3. hi i have a gp1300r 2007 please i need help
    By mike1706 in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 09-15-2009, 06:38 PM
  4. 2000 yama 1200r starter issues!!! please read and help me lol
    By 00gp1200r in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 06-03-2009, 12:22 AM
  5. Please i need help and im new in this faq with my gp1300r 03 spark????????
    By RAY82 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-13-2008, 01:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts